summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Savlook <isav@alzari.pw>2017-07-11 08:45:44 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-07-17 23:38:12 +0200
commit832ad1449fcbc8a81eed4712202f29ba8382b4b0 (patch)
treebda8e7ce5a49233f4bfe0b9ef34c2d133089fc48 /sys-fs/cryptmount
parentxfce-extra/tumbler: Bump to 0.2.0 (diff)
downloadgentoo-832ad1449fcbc8a81eed4712202f29ba8382b4b0.tar.gz
gentoo-832ad1449fcbc8a81eed4712202f29ba8382b4b0.tar.bz2
gentoo-832ad1449fcbc8a81eed4712202f29ba8382b4b0.zip
sys-fs/crypmount: new ebuild.
cryptmount allows management and user-mode mounting of encrypted filing systems on GNU/Linux systems. Filesystems & crypto-swap can be on either raw block devices or ordinary files, with device-mapper (dm-crypt) and loopback devices setup automatically. Gentoo-Bug: https://bugs.gentoo.org/624520 Closes: https://github.com/gentoo/gentoo/pull/5086
Diffstat (limited to 'sys-fs/cryptmount')
-rw-r--r--sys-fs/cryptmount/Manifest1
-rw-r--r--sys-fs/cryptmount/cryptmount-5.2.2.ebuild52
-rw-r--r--sys-fs/cryptmount/metadata.xml11
3 files changed, 64 insertions, 0 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
new file mode 100644
index 000000000000..fd79944ef9ac
--- /dev/null
+++ b/sys-fs/cryptmount/Manifest
@@ -0,0 +1 @@
+DIST cryptmount-5.2.2.tar.gz 743638 SHA256 2730782bcf1834e6f1b3575db1dde53e638d3679bc09d4eaf63111b428767859 SHA512 e8767728c49b7f8dc4f777778d5a9d1b912ea2c4c5363dbb5035a208aa1bd1f2565ce12a0666d75e9ee677bde04029082d20c22cf46a216f5e87a4adf7093572 WHIRLPOOL 772479a152b8ee3f2bb645b4d35a387522ba242b768a1d81b476734395d6696fa12923655e18e1bb69b07f15eeafa7a895dd4c7f685a9c93ac777cf87c6c0a1f
diff --git a/sys-fs/cryptmount/cryptmount-5.2.2.ebuild b/sys-fs/cryptmount/cryptmount-5.2.2.ebuild
new file mode 100644
index 000000000000..75d179508ab3
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-5.2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls +ssl systemd"
+
+
+DOCS=( AUTHORS ChangeLog NEWS README RELNOTES ToDo )
+
+RDEPEND="
+ dev-libs/libgcrypt
+ nls? ( virtual/libintl )
+ ssl? ( dev-libs/openssl )
+ systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="Please enable Device mapper support in your kernel config
+ -> Device Drivers
+ -> Multi-device support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM) (MD)
+ <M> Device mapper support"
+
+src_configure() {
+ econf \
+ --enable-cswap \
+ --enable-delegation \
+ --enable-fsck \
+ --enable-luks \
+ --with-libgcrypt \
+ $(use_enable nls) \
+ $(use_enable ssl openssl-compat) \
+ $(use_with systemd)
+}
+
+src_install() {
+ default
+}
diff --git a/sys-fs/cryptmount/metadata.xml b/sys-fs/cryptmount/metadata.xml
new file mode 100644
index 000000000000..33947efb5f37
--- /dev/null
+++ b/sys-fs/cryptmount/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sav@alzari.pw</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription>A utility for management and user-mode mounting of encrypted filesystems</longdescription>
+</pkgmetadata>