summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/fuseiso
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/fuseiso')
-rw-r--r--sys-fs/fuseiso/Manifest1
-rw-r--r--sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch12
-rw-r--r--sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch48
-rw-r--r--sys-fs/fuseiso/fuseiso-20070708-r1.ebuild29
-rw-r--r--sys-fs/fuseiso/metadata.xml8
5 files changed, 98 insertions, 0 deletions
diff --git a/sys-fs/fuseiso/Manifest b/sys-fs/fuseiso/Manifest
new file mode 100644
index 000000000000..243455bc549e
--- /dev/null
+++ b/sys-fs/fuseiso/Manifest
@@ -0,0 +1 @@
+DIST fuseiso-20070708.tar.bz2 239960 SHA256 8b242e077d66cd20900c59c905ff90b4c934b0613dd5a20facb0b1260ac5fd88 SHA512 d9d8153101494434fe4ec9c684cec46a1eee46fd3ce06e97fa27f4746990f866e1f23f256b2659e60296d2362cea05d259a0a2ef669ecddf7a0a7e44110c4ae0 WHIRLPOOL df6dd63a3e56cfbce8f85e37215c50d155ee9fb780a80a463c34b79ed1f7964cc3ba6d6b990e32dc991020be309bfdd08a2866ebf3eeedda03ed8262687a1fb4
diff --git a/sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch b/sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch
new file mode 100644
index 000000000000..522ee7598e0e
--- /dev/null
+++ b/sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch
@@ -0,0 +1,12 @@
+diff -urp fuseiso-20070708.org/src/fuseiso.c fuseiso-20070708/src/fuseiso.c
+--- fuseiso-20070708.org/src/fuseiso.c 2013-08-22 19:33:46.316904170 +0800
++++ fuseiso-20070708/src/fuseiso.c 2013-08-22 19:31:54.789908834 +0800
+@@ -295,7 +295,7 @@ void usage(const char* prog) {
+ " -f -- run in foreground, do not daemonize\n"
+ " -d -- run in foreground and print debug information\n"
+ " -s -- run single-threaded\n"
+- "\nPlease consult with FUSE ducumentation for more information\n",
++ "\nPlease consult with FUSE documentation for more information\n",
+ VERSION,
+ prog);
+ };
diff --git a/sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch b/sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch
new file mode 100644
index 000000000000..e323768d247e
--- /dev/null
+++ b/sys-fs/fuseiso/files/fuseiso-20070708-largeiso.patch
@@ -0,0 +1,48 @@
+http://bugzilla.redhat.com/show_bug.cgi?id=440436
+
+diff -ur fuseiso-20070708.orig/src/isofs.c fuseiso-20070708/src/isofs.c
+--- fuseiso-20070708.orig/src/isofs.c 2007-07-08 15:22:59.000000000 +0300
++++ fuseiso-20070708/src/isofs.c 2009-10-25 12:02:16.000000000 +0200
+@@ -178,7 +178,7 @@
+ context.data_size = isonum_723(context.pd.logical_block_size);
+
+ if(!context.block_size) {
+- fprintf(stderr, "init: wrong block data size %d, using default 2048\n", context.data_size);
++ fprintf(stderr, "init: wrong block data size %Lu, using default 2048\n", context.data_size);
+ context.data_size = 2048;
+ };
+
+@@ -324,7 +324,7 @@
+
+ if(context.block_size != 2048) {
+ // report unusual data block size
+- printf("Data block size: %d\n", context.block_size);
++ printf("Data block size: %Lu\n", context.block_size);
+ };
+
+ char buf[129];
+@@ -479,7 +479,7 @@
+ };
+ size_t len = read(context.fd, buf, context.data_size);
+ if(len != context.data_size) {
+- fprintf(stderr, "isofs_read_raw_block: can`t read full block, read only %d bytes from offset %d, %d required; errno %d, message %s\n",
++ fprintf(stderr, "isofs_read_raw_block: can`t read full block, read only %d bytes from offset %d, %Lu required; errno %d, message %s\n",
+ len, (int) off, context.data_size, errno, strerror(errno));
+ fprintf(stderr, "isofs_read_raw_block: huh? reading zeros beyond file end? someone want to save a penny?\n");
+ memset(buf + len, 0, context.data_size - len);
+diff -ur fuseiso-20070708.orig/src/isofs.h fuseiso-20070708/src/isofs.h
+--- fuseiso-20070708.orig/src/isofs.h 2006-10-17 04:50:39.000000000 +0300
++++ fuseiso-20070708/src/isofs.h 2009-10-25 12:02:16.000000000 +0200
+@@ -38,9 +38,9 @@
+ struct iso_directory_record *root;
+ int file_offset; // offset to begin of useful data (for .nrg files)
+ int id_offset; // offset to CD001 inside file
+- size_t block_size; // raw block size
+- size_t block_offset; // offset from block start to data
+- size_t data_size; // data size inside block
++ off_t block_size; // raw block size
++ off_t block_offset; // offset from block start to data
++ off_t data_size; // data size inside block
+ int susp; // parse susp entries
+ int susp_skip; // skip bytes from susp SP entry
+ int joliet_level; // joliet extension level (1, 2 or 3)
diff --git a/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild b/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild
new file mode 100644
index 000000000000..9acd2cf4f5fa
--- /dev/null
+++ b/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Fuse module to mount ISO9660"
+HOMEPAGE="http://sourceforge.net/projects/fuseiso"
+SRC_URI="http://superb-dca2.dl.sourceforge.net/project/fuseiso/fuseiso/20070708/fuseiso-20070708.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-fs/fuse
+ sys-libs/zlib
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-largeiso.patch"
+ epatch "${FILESDIR}/${P}-fix-typo.patch" # bug #482078
+ epatch_user
+}
diff --git a/sys-fs/fuseiso/metadata.xml b/sys-fs/fuseiso/metadata.xml
new file mode 100644
index 000000000000..2f90b14e8632
--- /dev/null
+++ b/sys-fs/fuseiso/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>zhaoxiaoqiang007@gmail.com</email>
+ </maintainer>
+</pkgmetadata>