summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-10-21 09:35:44 +0100
committerJustin Lecher <jlec@gentoo.org>2017-10-21 09:41:57 +0100
commit14b26839ad36502ba7bdc4108974eeceb40e5e06 (patch)
tree0ff0720a998486e6c2511b0c5ed04302983afcae /sys-fs
parentsys-cluster/singularity: Version Bump (diff)
downloadgentoo-14b26839ad36502ba7bdc4108974eeceb40e5e06.tar.gz
gentoo-14b26839ad36502ba7bdc4108974eeceb40e5e06.tar.bz2
gentoo-14b26839ad36502ba7bdc4108974eeceb40e5e06.zip
sys-fs/aufs4: Version Bump
############################################################################### # Commit message goes until here ############################################################################### sys-fs/aufs4/aufs4-0_pre20171002.ebuild | 184 ++++++++++++++++++++++++++++++++ 1 file changed, 184 insertions(+) diff --git a/sys-fs/aufs4/aufs4-0_pre20171002.ebuild b/sys-fs/aufs4/aufs4-0_pre20171002.ebuild new file mode 100644 index 00000000000..2f61f36acc1 --- /dev/null +++ b/sys-fs/aufs4/aufs4-0_pre20171002.ebuild @@ -0,0 +1,184 @@ +# Copyright 1999-2017 Gentoo Foundation +# Distributed under the terms of the GNU General Public License v2 + +EAPI=6 + +inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo-r1 toolchain-funcs + +AUFS_VERSION="${PV%%_p*}" +# highest branch version +PATCH_MAX_VER=13 +# highest supported version +KERN_MAX_VER=14 +# lowest supported version +KERN_MIN_VER=0 + +DESCRIPTION="An entirely re-designed and re-implemented Unionfs" +HOMEPAGE="http://aufs.sourceforge.net/" +SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz" + +LICENSE="GPL-2" +SLOT="0" +KEYWORDS="~amd64 ~x86" +IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs" + +DEPEND=" + dev-util/patchutils + dev-vcs/git" +RDEPEND=" + sys-fs/aufs-util + !sys-fs/aufs + !sys-fs/aufs2 + !sys-fs/aufs3" + +S="${WORKDIR}"/${PN}-standalone + +MODULE_NAMES="aufs(misc:${S})" + +pkg_setup() { + CONFIG_CHECK+=" !AUFS_FS" + use inotify && CONFIG_CHECK+=" ~FSNOTIFY" + use nfs && CONFIG_CHECK+=" EXPORTFS" + use fuse && CONFIG_CHECK+=" ~FUSE_FS" + use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS" + use pax_kernel && CONFIG_CHECK+=" PAX" \ + && ERROR_PAX="Please use hardened sources" + + # this is needed so merging a binpkg ${PN} is + # possible w/out a kernel unpacked on the system + [[ -n "$PKG_SETUP_HAS_BEEN_RAN" ]] && return + + get_version + kernel_is lt 4 ${KERN_MIN_VER} 0 && \ + die "the kernel version isn't supported by upstream anymore. Please upgrade." + kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new" + + linux-mod_pkg_setup + + if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then + PATCH_BRANCH="x-rcN" + elif [[ "${KV_MINOR}" == "1" ]] && [[ "${KV_PATCH}" -ge "13" ]]; then + PATCH_BRANCH="${KV_MINOR}".13+ + else + PATCH_BRANCH="${KV_MINOR}" + fi + + case ${KV_EXTRA} in + "") + elog "It seems you are using vanilla-sources with aufs4" + elog "Please use sys-kernel/aufs-sources with USE=vanilla" + elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade" + ;; + "-gentoo") + elog "It seems you are using gentoo-sources with aufs4" + elog "Please use sys-kernel/aufs-sources" + elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade" + ;; + esac + + pushd "${T}" &> /dev/null || die + unpack ${A} + + cd ${PN}-standalone || die + + local module_branch=origin/${PN}.${PATCH_BRANCH} + + einfo "Using ${module_branch} as patch source" + git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die + + combinediff \ + ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch + combinediff \ + "${T}"/combined-1.patch ${PN}-mmap.patch \ + > ${PN}-standalone-base-mmap-combined.patch + + if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then + if use kernel-patch; then + cd ${KV_DIR} + ewarn "Patching your kernel..." + patch \ + --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} \ + < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch \ + > /dev/null + epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch + ewarn "You need to compile your kernel with the applied patch" + ewarn "to be able to load and use the aufs kernel module" + else + eerror "You need to apply a patch to your kernel to compile and run the ${PN} module" + eerror "Either enable the kernel-patch useflag to do it with this ebuild" + eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand" + die "missing kernel patch, please apply it first" + fi + fi + + popd &> /dev/null + export PKG_SETUP_HAS_BEEN_RAN=1 +} + +set_config() { + for option in $*; do + grep -q "^CONFIG_AUFS_${option} =" config.mk || \ + die "${option} is not a valid config option" + sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die + done +} + +src_prepare() { + local module_branch=origin/${PN}.${PATCH_BRANCH} + + einfo "Using for module creation branch ${module_branch}" + git checkout -q -b local-gentoo ${module_branch} || die + + # All config options to off + sed "s:= y:=:g" -i config.mk || die + + set_config RDU BRANCH_MAX_127 SBILIST + + use debug && set_config DEBUG + use fuse && set_config BR_FUSE POLL + use hfs && set_config BR_HFSPLUS + use inotify && set_config HNOTIFY HFSNOTIFY + use nfs && set_config EXPORT + use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64 + use ramfs && set_config BR_RAMFS + + use pax_kernel && epatch "${FILESDIR}"/pax-4.patch + + sed \ + -e "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" \ + -i Makefile || die + + eapply_user +} + +src_compile() { + local ARCH=x86 + + emake \ + CC=$(tc-getCC) \ + LD=$(tc-getLD) \ + LDFLAGS="$(raw-ldflags)" \ + ARCH=$(tc-arch-kernel) \ + CONFIG_AUFS_FS=m \ + KDIR="${KV_OUT_DIR}" +} + +src_install() { + linux-mod_src_install + + use doc && dodoc -r Documentation + + use kernel-patch || \ + doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch + + dodoc \ + Documentation/filesystems/aufs/README \ + "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch + + readme.gentoo_create_doc +} + +pkg_postinst() { + readme.gentoo_print_elog + linux-mod_pkg_postinst +} Package-Manager: Portage-2.3.10, Repoman-2.3.3 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs4/Manifest1
-rw-r--r--sys-fs/aufs4/aufs4-0_pre20171002.ebuild184
2 files changed, 185 insertions, 0 deletions
diff --git a/sys-fs/aufs4/Manifest b/sys-fs/aufs4/Manifest
index ac4d7e7870b6..4579c71bccb3 100644
--- a/sys-fs/aufs4/Manifest
+++ b/sys-fs/aufs4/Manifest
@@ -8,3 +8,4 @@ DIST aufs4-standalone-0_pre20170130.tar.xz 1761280 SHA256 ea854a64dabfb6b2d6c6be
DIST aufs4-standalone-0_pre20170220.tar.xz 2115232 SHA256 96dcb9d94d1d2358a61e9d5cdfb9c9e6e4886018f5d24a76ab8deb7e03b7f04f SHA512 c68cf12573a0f3d9ec9419c63759d2b6f120eaafbbc005553c31d9c07b77d61612b903dc7ebdb2a8de8a52ded62e20b08cd32206b3cd3df196f0c1da82d472f7 WHIRLPOOL a2a3f10d003999a9498978a7b0d013cf918070cad975bfe54429d158d980943864fd810178a0639925d54c33974d13fa782950c77756469c646ebc57ddd6f917
DIST aufs4-standalone-0_pre20170313.tar.xz 1883012 SHA256 195b0a821fe9fe7f22416848699bb464434d6c7562d981a3fa64f8670234b516 SHA512 7d711e0ebdc38aa79d3b7cdb04c91f3029c233bacdadca87a8622d48826c261c678d6a2cda6b627a0db0f248b35448e0d9da30e2c8e2e42e3b1e3ae6327033ba WHIRLPOOL 41410d251ede7e85faee6aaac4139aa00862f7dfdf4eeef6baef72f0324d594cf48c416d3d3dc7ff98ad0563d3b7b0b3c20f75784947660947b20a74331d89c7
DIST aufs4-standalone-0_pre20170612.tar.xz 2017248 SHA256 fe725b22ace944b26cc33a79fe8cb977824937473ee4b67b95d62854da1dd589 SHA512 2d0fd1dce7b1a421533e667420fc69a44c378753dccddc3768eebdb906a023e41378b38961004a58b1c4f2e3844c86f8cb4be238e634318a380881eab513acfa WHIRLPOOL c74bea33b077e3dda7abe165daf0e5c54e1949f6b3d3928b47e50d13e9dee1a9b2a49605b85d9afb52dd36c69a61c1f07969e4a05da0aa705051d719b8a86776
+DIST aufs4-standalone-0_pre20171002.tar.xz 2265048 SHA256 89ed39c84ad9d30a479b9bc5039dcdd37c0a88d61055a9935e364e23a12a2d59 SHA512 ee9d0e48fba6671fe4c5d3f533956c3eb0c6caa45fc4074be94f4427d84a5446cd4dc9f3ebf27fb56e697b24172ddd14a61c246f0414ebce8e372c204dfbb150 WHIRLPOOL 178ece388bd30c2d3aeef226f5fc03910513df7902f208ca14dfd4a841c453db38fc48ade8c18e0801142cdb4d592d2f4d13f68369a74eed32bb8ee4a3465e3c
diff --git a/sys-fs/aufs4/aufs4-0_pre20171002.ebuild b/sys-fs/aufs4/aufs4-0_pre20171002.ebuild
new file mode 100644
index 000000000000..2f61f36acc1d
--- /dev/null
+++ b/sys-fs/aufs4/aufs4-0_pre20171002.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo-r1 toolchain-funcs
+
+AUFS_VERSION="${PV%%_p*}"
+# highest branch version
+PATCH_MAX_VER=13
+# highest supported version
+KERN_MAX_VER=14
+# lowest supported version
+KERN_MIN_VER=0
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
+
+DEPEND="
+ dev-util/patchutils
+ dev-vcs/git"
+RDEPEND="
+ sys-fs/aufs-util
+ !sys-fs/aufs
+ !sys-fs/aufs2
+ !sys-fs/aufs3"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK+=" !AUFS_FS"
+ use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
+ use nfs && CONFIG_CHECK+=" EXPORTFS"
+ use fuse && CONFIG_CHECK+=" ~FUSE_FS"
+ use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
+ use pax_kernel && CONFIG_CHECK+=" PAX" \
+ && ERROR_PAX="Please use hardened sources"
+
+ # this is needed so merging a binpkg ${PN} is
+ # possible w/out a kernel unpacked on the system
+ [[ -n "$PKG_SETUP_HAS_BEEN_RAN" ]] && return
+
+ get_version
+ kernel_is lt 4 ${KERN_MIN_VER} 0 && \
+ die "the kernel version isn't supported by upstream anymore. Please upgrade."
+ kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ elif [[ "${KV_MINOR}" == "1" ]] && [[ "${KV_PATCH}" -ge "13" ]]; then
+ PATCH_BRANCH="${KV_MINOR}".13+
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ case ${KV_EXTRA} in
+ "")
+ elog "It seems you are using vanilla-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources with USE=vanilla"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ "-gentoo")
+ elog "It seems you are using gentoo-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ esac
+
+ pushd "${T}" &> /dev/null || die
+ unpack ${A}
+
+ cd ${PN}-standalone || die
+
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using ${module_branch} as patch source"
+ git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
+
+ combinediff \
+ ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff \
+ "${T}"/combined-1.patch ${PN}-mmap.patch \
+ > ${PN}-standalone-base-mmap-combined.patch
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch \
+ --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} \
+ < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch \
+ > /dev/null
+ epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+
+ popd &> /dev/null
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || \
+ die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ use pax_kernel && epatch "${FILESDIR}"/pax-4.patch
+
+ sed \
+ -e "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" \
+ -i Makefile || die
+
+ eapply_user
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake \
+ CC=$(tc-getCC) \
+ LD=$(tc-getLD) \
+ LDFLAGS="$(raw-ldflags)" \
+ ARCH=$(tc-arch-kernel) \
+ CONFIG_AUFS_FS=m \
+ KDIR="${KV_OUT_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ use doc && dodoc -r Documentation
+
+ use kernel-patch || \
+ doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+
+ dodoc \
+ Documentation/filesystems/aufs/README \
+ "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ linux-mod_pkg_postinst
+}