summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-11-21 14:51:35 -0500
committerMike Gilbert <floppym@gentoo.org>2022-11-21 14:51:35 -0500
commita05d2535777027dd8d43197b865768da4baf2126 (patch)
tree30c631f4384ddf67309c200553299e8af2b4bd4e /sys-fs
parentdev-python/ipdb: Keyword 0.13.9-r3 ia64, #873718 (diff)
downloadgentoo-a05d2535777027dd8d43197b865768da4baf2126.tar.gz
gentoo-a05d2535777027dd8d43197b865768da4baf2126.tar.bz2
gentoo-a05d2535777027dd8d43197b865768da4baf2126.zip
sys-fs/lvm2: fix build with USE="sanlock -systemd"
Closes: https://bugs.gentoo.org/822054 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/lvm2-2.03.14-r4.ebuild1
-rw-r--r--sys-fs/lvm2/lvm2-2.03.16-r2.ebuild1
-rw-r--r--sys-fs/lvm2/lvm2-2.03.17.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/sys-fs/lvm2/lvm2-2.03.14-r4.ebuild b/sys-fs/lvm2/lvm2-2.03.14-r4.ebuild
index b8512c8bc5ce..b991a1ef1218 100644
--- a/sys-fs/lvm2/lvm2-2.03.14-r4.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.14-r4.ebuild
@@ -103,6 +103,7 @@ src_prepare() {
# Users without systemd get no auto-activation of any logical volume
if ! use systemd ; then
eapply "${FILESDIR}"/${PN}-2.03.14-dm_lvm_rules_no_systemd.patch
+ sed -i -e '/^USE_SD_NOTIFY=yes$/s/yes/no/' daemons/lvmlockd/Makefile.in || die
fi
sed -i \
diff --git a/sys-fs/lvm2/lvm2-2.03.16-r2.ebuild b/sys-fs/lvm2/lvm2-2.03.16-r2.ebuild
index dca72ccfd4a0..4b49e8d27e66 100644
--- a/sys-fs/lvm2/lvm2-2.03.16-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.16-r2.ebuild
@@ -108,6 +108,7 @@ src_prepare() {
# Users without systemd get no auto-activation of any logical volume
if ! use systemd ; then
eapply "${FILESDIR}"/${PN}-2.03.16-dm_lvm_rules_no_systemd.patch
+ sed -i -e '/^USE_SD_NOTIFY=yes$/s/yes/no/' daemons/lvmlockd/Makefile.in || die
fi
sed -i \
diff --git a/sys-fs/lvm2/lvm2-2.03.17.ebuild b/sys-fs/lvm2/lvm2-2.03.17.ebuild
index 01f3f1dd4f90..91f4b5074807 100644
--- a/sys-fs/lvm2/lvm2-2.03.17.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.17.ebuild
@@ -107,6 +107,7 @@ src_prepare() {
# Users without systemd get no auto-activation of any logical volume
if ! use systemd ; then
eapply "${FILESDIR}"/${PN}-2.03.16-dm_lvm_rules_no_systemd.patch
+ sed -i -e '/^USE_SD_NOTIFY=yes$/s/yes/no/' daemons/lvmlockd/Makefile.in || die
fi
sed -i -e "s:/usr/bin/true:$(type -P true):" scripts/blk_availability_systemd_red_hat.service.in || die #517514