summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-15 04:19:32 +0100
committerSam James <sam@gentoo.org>2021-10-15 04:20:28 +0100
commitb99b21377e23907dcb9986ef1ebfdc30b931c235 (patch)
tree1f4057bfc9a22ccc87db2246eaa6f63e975ef668 /sys-fs
parentnet-mail/onionrouter: Cleanup old version (diff)
downloadgentoo-b99b21377e23907dcb9986ef1ebfdc30b931c235.tar.gz
gentoo-b99b21377e23907dcb9986ef1ebfdc30b931c235.tar.bz2
gentoo-b99b21377e23907dcb9986ef1ebfdc30b931c235.zip
sys-fs/squashfs-tools: add 4.5_p20210914
Contains a fix for a CVE (CVE-2021-41072) but also a few regressions and follow up fixes. Upstream say there's a new version coming soon but best not to wait. Closes: https://bugs.gentoo.org/811474 Bug: https://bugs.gentoo.org/811474 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/Manifest1
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.5_p20210914.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
index 30d14da8e104..2f241ef9a54b 100644
--- a/sys-fs/squashfs-tools/Manifest
+++ b/sys-fs/squashfs-tools/Manifest
@@ -1 +1,2 @@
DIST squashfs-tools-4.5.tar.gz 250471 BLAKE2B 2fc8ab9bb6565b97656afd63b76bfd7449d96b83697286e88b55a8cd82957b395df17a707ee93e8a99ed19dc5ba73966ce33530ef6c35797924dad4e3f16ed3b SHA512 e00610487d24eed9e5dadcf84014a3d7faa9815d8ce00fd4660e6c8ce394dccf185ed9f387f4fa1313b9812fe770f802bdcbaef87887f2bcefacf234594a72e0
+DIST squashfs-tools-4.5_p20210914.tar.gz 252104 BLAKE2B f3e2e281c30464b3c2e9b2a3520979f90ccb83665ac61a2f68513b402d8ef658621fc75c782c2f42da20ddf51f884e2ccc6217df941790fd45b41f3f4e3ec970 SHA512 a814092be787bbcbd4115f87493a63b67caa364ad88fe5a3c82808083343cbcbc22b4617bd5c72d65d8abe2b11eb77853bcc55c11f5cd5dc3edf24bd27cbd135
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.5_p20210914.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.5_p20210914.ebuild
new file mode 100644
index 000000000000..66c6618def05
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.5_p20210914.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic toolchain-funcs
+
+MY_COMMIT="19fcc9365dcdb2c22d232d42d11012940df64b7c"
+MY_P=${P/_p/-git.}
+DESCRIPTION="tools to create and extract Squashfs filesystems"
+HOMEPAGE="https://github.com/plougher/squashfs-tools/"
+SRC_URI="https://github.com/plougher/squashfs-tools/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${MY_COMMIT}
+
+#SRC_URI="
+# https://github.com/plougher/squashfs-tools/archive/${PV/_p/-git.}.tar.gz
+# -> ${MY_P}.tar.gz"
+#S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="debug lz4 lzma lzo xattr zstd"
+
+RDEPEND="
+ sys-libs/zlib
+ lz4? ( app-arch/lz4 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ xattr? ( sys-apps/attr )
+ zstd? ( app-arch/zstd )
+"
+DEPEND=${RDEPEND}
+
+use10() { usex "${1}" 1 0; }
+
+src_configure() {
+ # set up make command line variables in EMAKE_SQUASHFS_CONF
+ EMAKE_SQUASHFS_CONF=(
+ LZMA_XZ_SUPPORT=$(use10 lzma)
+ LZO_SUPPORT=$(use10 lzo)
+ LZ4_SUPPORT=$(use10 lz4)
+ XATTR_SUPPORT=$(use10 xattr)
+ XZ_SUPPORT=$(use10 lzma)
+ ZSTD_SUPPORT=$(use10 zstd)
+ )
+
+ tc-export CC
+ use debug && append-cppflags -DSQUASHFS_TRACE
+}
+
+src_compile() {
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C squashfs-tools
+}
+
+src_install() {
+ dobin squashfs-tools/{mksquashfs,unsquashfs}
+ dodoc ACKNOWLEDGEMENTS CHANGES README*
+ dodoc -r RELEASE-READMEs
+}