summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-30 22:07:42 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-10-30 22:08:35 +0100
commite04bc2e851ac54864c388a674af9d0ce3c83ff66 (patch)
tree15cc7a4d0b130c0013d2efedb61673b3698f8354 /sys-fs
parentdev-python/pytest-mock: require mock-2 (bug 635800) (diff)
downloadgentoo-e04bc2e851ac54864c388a674af9d0ce3c83ff66.tar.gz
gentoo-e04bc2e851ac54864c388a674af9d0ce3c83ff66.tar.bz2
gentoo-e04bc2e851ac54864c388a674af9d0ce3c83ff66.zip
sys-fs/dd-rescue: Rev bump to fix build issue on ARM caused by MUSL patch
In addition: - OpenSSL removal updated (crypto_EVP_aes_192_ctr lib check) - lzo USE flag handling fixed (HAVE_LZO_LZO1X_H caused to build with lzo even when USE=-lzo was set but dev-libs/lzo was installed) - HMAC tests disabled due to https://sourceforge.net/p/ddrescue/tickets/3/ Closes: https://bugs.gentoo.org/616364 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.99.6-r1.ebuild93
-rw-r--r--sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch21
-rw-r--r--sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch161
3 files changed, 275 insertions, 0 deletions
diff --git a/sys-fs/dd-rescue/dd-rescue-1.99.6-r1.ebuild b/sys-fs/dd-rescue/dd-rescue-1.99.6-r1.ebuild
new file mode 100644
index 000000000000..1d391a112ea3
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.99.6-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs flag-o-matic multilib autotools
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cpu_flags_x86_avx2 lzo cpu_flags_x86_sse4_2 static xattr"
+
+RDEPEND="lzo? ( dev-libs/lzo )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${MY_PN}-1.99-musl-r1.patch
+ "${FILESDIR}"/${MY_PN}-1.99-disable-hmac-tests.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:-ldl:$(LDFLAGS) -ldl:' \
+ -e 's:-shared:$(CFLAGS) $(LDFLAGS) -shared:' \
+ Makefile || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ # OpenSSL is only used by a random helper tool we don't install.
+ ac_cv_header_attr_xattr_h=$(usex xattr) \
+ ac_cv_header_openssl_evp_h=no \
+ ac_cv_lib_crypto_EVP_aes_192_ctr=no \
+ ac_cv_lib_lzo2_lzo1x_1_compress=$(usex lzo) \
+ ac_cv_header_lzo_lzo1x_h=$(usex lzo) \
+ econf
+}
+
+_emake() {
+ local arch
+ case ${ARCH} in
+ x86) arch=i386;;
+ amd64) arch=x86_64;;
+ arm) arch=arm;;
+ arm64) arch=aarch64;;
+ esac
+
+ local os=$(usex kernel_linux Linux IDK)
+
+ # The Makefile is a mess. Override a few vars rather than patch it.
+ emake \
+ MACH="${arch}" \
+ OS="${os}" \
+ HAVE_SSE42=$(usex cpu_flags_x86_sse4_2 1 0) \
+ HAVE_AVX2=$(usex cpu_flags_x86_avx2 1 0) \
+ RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS_OPT='$(CFLAGS)' \
+ LDFLAGS="${LDFLAGS} -Wl,-rpath,${EPREFIX%/}/usr/$(get_libdir)/${PN}" \
+ CC="$(tc-getCC)" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ # easier to install by hand than trying to make sense of the Makefile.
+ dobin dd_rescue
+ dodir /usr/$(get_libdir)/${PN}
+ cp -pPR libddr_*.so "${ED%/}"/usr/$(get_libdir)/${PN}/ || die
+ dodoc README.dd_rescue
+ doman dd_rescue.1
+ use lzo && doman ddr_lzo.1
+}
diff --git a/sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch b/sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch
new file mode 100644
index 000000000000..244f43121399
--- /dev/null
+++ b/sys-fs/dd-rescue/files/dd_rescue-1.99-disable-hmac-tests.patch
@@ -0,0 +1,21 @@
+https://sourceforge.net/p/ddrescue/tickets/3/
+
+--- a/Makefile
++++ b/Makefile
+@@ -500,11 +500,11 @@ check: $(TARGETS) find_nonzero md5 sha1 sha256 sha512 fmt_no
+ # Extra xattrs (should be preserved)
+ #make check_xattr_copy
+ # Tests with HMAC
+- echo -n "what do ya want for nothing?" > TEST
+- echo "750c783e6ab0b503eaa86e310a5db738 *TEST" > HMACS.md5
+- $(VG) ./dd_rescue -L ./libddr_hash.so=md5:hmacpwd=Jefe:chknm= TEST /dev/null
+- rm -f /tmp/dd_rescue CHECKSUMS.sha512 TEST HMACS.md5
+- if ./calchmac.py sha1 pass dd_rescue; then $(MAKE) check_hmac; else echo "Sorry, no more HMAC test due to missing python-hashlib support"; true; fi
++ #echo -n "what do ya want for nothing?" > TEST
++ #echo "750c783e6ab0b503eaa86e310a5db738 *TEST" > HMACS.md5
++ #$(VG) ./dd_rescue -L ./libddr_hash.so=md5:hmacpwd=Jefe:chknm= TEST /dev/null
++ #rm -f /tmp/dd_rescue CHECKSUMS.sha512 TEST HMACS.md5
++ #if ./calchmac.py sha1 pass dd_rescue; then $(MAKE) check_hmac; else echo "Sorry, no more HMAC test due to missing python-hashlib support"; true; fi
+ $(MAKE) check_fault
+ #$(MAKE) check_aes
+ $(MAKE) check_crypt
diff --git a/sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch b/sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch
new file mode 100644
index 000000000000..6751cf009866
--- /dev/null
+++ b/sys-fs/dd-rescue/files/dd_rescue-1.99-musl-r1.patch
@@ -0,0 +1,161 @@
+From 66e7503f24b9693ddb20a0873ae054f799c3660f Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Mon, 30 Oct 2017 20:12:10 +0100
+Subject: [PATCH 49/49] loff_t and __WORDSIZE includes for MUSL
+
+Rewrite of Justin Keogh's patch [Link 1] to fix build problems
+on ARM.
+
+Link 1: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f5abc0f1b036921d6eb5b0f434c960ed280619f
+Fixes: https://bugs.gentoo.org/616364
+---
+ configure.in | 2 +-
+ ddr_ctrl.h | 3 +++
+ ffs.h | 3 +++
+ fiemap.h | 4 ++++
+ fmt_no.h | 2 ++
+ fstrim.h | 3 +++
+ libddr_hash.c | 4 ++++
+ libddr_lzo.c | 3 +++
+ libddr_null.c | 3 +++
+ sha512.h | 4 ++++
+ 10 files changed, 30 insertions(+), 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index f813d4b..c9d28c5 100644
+--- a/configure.in
++++ b/configure.in
+@@ -6,7 +6,7 @@ AC_C_INLINE
+ AC_HEADER_STDC
+ #AC_PROG_INSTALL
+ #CFLAGS="$CFLAGS -DHAVE_CONFIG_H"
+-AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h attr/xattr.h sys/acl.h sys/ioctl.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h malloc.h sched.h sys/statvfs.h])
++AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h attr/xattr.h sys/acl.h sys/ioctl.h sys/reg.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h malloc.h sched.h sys/statvfs.h])
+ AC_CHECK_FUNCS([ffs ffsl basename fallocate64 splice getopt_long open64 pread pread64 lseek64 stat64 posix_fadvise posix_fadvise64 __builtin_prefetch htobe64 feof_unlocked getline getentropy getrandom posix_memalign valloc sched_yield fstatvfs])
+ AC_CHECK_LIB(dl,dlsym)
+ AC_CHECK_LIB(fallocate,linux_fallocate64)
+diff --git a/ddr_ctrl.h b/ddr_ctrl.h
+index ac71e4f..58cffd5 100644
+--- a/ddr_ctrl.h
++++ b/ddr_ctrl.h
+@@ -7,6 +7,9 @@
+ * License: GNU GPLv2 or v3
+ */
+
++#define _GNU_SOURCE
++#include <fcntl.h>
++
+ #ifndef _DDR_CTRL_H
+ #define _DDR_CTRL_H
+
+diff --git a/ffs.h b/ffs.h
+index 2215080..c1f3444 100644
+--- a/ffs.h
++++ b/ffs.h
+@@ -28,6 +28,9 @@
+ #include <endian.h>
+ #endif
+
++#ifdef HAVE_SYS_REG_H
++#include <sys/reg.h>
++#endif
+
+ #ifdef HAVE_FFS
+ # define myffs(x) ffs(x)
+diff --git a/fiemap.h b/fiemap.h
+index df1ba95..31cde3b 100644
+--- a/fiemap.h
++++ b/fiemap.h
+@@ -29,5 +29,9 @@
+
+ #endif /* HAVE_LINUX_FS_H */
+
++#ifdef HAVE_SYS_REG_H
++#include <sys/reg.h>
++#endif
++
+ #endif /* _FIEMAPH */
+
+diff --git a/fmt_no.h b/fmt_no.h
+index 329f997..16eda5c 100644
+--- a/fmt_no.h
++++ b/fmt_no.h
+@@ -1,4 +1,6 @@
+ /** Decl for int to str conversion with highlighting */
++#define _GNU_SOURCE
++#include <fcntl.h>
+
+ #ifndef _FMT_NO_H
+ #define _FMT_NO_H
+diff --git a/fstrim.h b/fstrim.h
+index 7447061..b9cdcbb 100644
+--- a/fstrim.h
++++ b/fstrim.h
+@@ -1,3 +1,6 @@
++#define _GNU_SOURCE
++#include <fcntl.h>
++
+ #ifndef _FSTRIM_H
+ #define _FSTRIM_H
+
+diff --git a/libddr_hash.c b/libddr_hash.c
+index daa806e..264dba1 100644
+--- a/libddr_hash.c
++++ b/libddr_hash.c
+@@ -33,6 +33,10 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+
++#ifdef HAVE_SYS_REG_H
++#include <sys/reg.h>
++#endif
++
+ #include <netinet/in.h> /* For ntohl/htonl */
+ #include <endian.h>
+
+diff --git a/libddr_lzo.c b/libddr_lzo.c
+index 531df11..3220e2a 100644
+--- a/libddr_lzo.c
++++ b/libddr_lzo.c
+@@ -26,6 +26,9 @@
+ #include <errno.h>
+ #include <netinet/in.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_REG_H
++#include <sys/reg.h>
++#endif
+ #include <signal.h>
+ #include <lzo/lzo1x.h>
+ #include <lzo/lzo1y.h>
+diff --git a/libddr_null.c b/libddr_null.c
+index 3f0f194..c379961 100644
+--- a/libddr_null.c
++++ b/libddr_null.c
+@@ -10,6 +10,9 @@
+ #include "ddr_ctrl.h"
+ #include <string.h>
+ #include <stdlib.h>
++#ifdef HAVE_SYS_REG_H
++#include <sys/reg.h>
++#endif
+
+ /* fwd decl */
+ extern ddr_plugin_t ddr_plug;
+diff --git a/sha512.h b/sha512.h
+index 4d08043..f54d371 100644
+--- a/sha512.h
++++ b/sha512.h
+@@ -3,6 +3,10 @@
+
+ #include "hash.h"
+
++#ifdef HAVE_SYS_REG_H
++#include <sys/reg.h>
++#endif
++
+ void sha512_init(hash_t *ctx);
+ void sha384_init(hash_t *ctx);
+ void sha512_128(const uint8_t* msg, hash_t* ctx);
+--
+2.14.3
+