summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2023-01-30 15:36:37 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2023-01-30 15:36:37 +0900
commit6cd9017b061051ccaa2762e442e84199212aaca8 (patch)
tree0ed8289d059f0d60c3af8cc8d56ac33748050d24 /sys-kernel
parentmail-client/thunderbird: drop 102.6.0 (diff)
downloadgentoo-6cd9017b061051ccaa2762e442e84199212aaca8.tar.gz
gentoo-6cd9017b061051ccaa2762e442e84199212aaca8.tar.bz2
gentoo-6cd9017b061051ccaa2762e442e84199212aaca8.zip
sys-kernel/git-sources: add 6.2_rc6
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.2_rc6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index b2f9a485bfef..f976a6ee79bf 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-6.2-rc2.patch 62009581 BLAKE2B b17cc02211a6c6c3f97eb8dd8896c572ea1dce
DIST patch-6.2-rc3.patch 62224587 BLAKE2B e873338f80f379aceb3444e3e397014c1b91f1cb012e3080063e1d33c7339d84da25402fb40711f9c496becbedbd73935226f97061f8747e51022c3400f57c66 SHA512 a1a86364b57a03b3122dd54a012ad6de65696f21140d2958700668c9a63c3cc052ac2670177e188384961310568faabe87c351608efdf7dde69d4bdb6248c3f2
DIST patch-6.2-rc4.patch 62686618 BLAKE2B 4f67e021c76b1d9f028813826c49f66795b46fcf558e906d3d2d03072522e21d99da96d92803f1252ac1a2f3b32946df90ae6fc4bef3c8ed6f0100e0fefd54eb SHA512 8e65854464e53b62452e5e80119e53fd61b3bdc2e5de262a44030208a07f811541f7d4e3af647afffbead7c96f0a6b9a81e6e17c95575d0cd6eaf6ea9f708fff
DIST patch-6.2-rc5.patch 63046709 BLAKE2B 234ac71b0803b802c5fa54d1eef452ae1e76c9ed2b61638a357a4ccf851a38fb1ad1697a468059d5bd443c20d6cd799bf917aafd9801177b9ccd62f28255473f SHA512 bf7aeaca8fe6c4476f2b346b3f1bc88fba4e9da9cf12a2668baa2e73ba0a5a443fbde995909994db903b2ca64e58ed4aae1ff0cad539cee4d3712067f73e4220
+DIST patch-6.2-rc6.patch 63222751 BLAKE2B ca5572d4bd8fa547cac49210fd8204a65e0d1cc7d8c8bf386be88c7c4f7ad0c72048c8ceeea21574978947f75e8837b1b63a782ec3508641d1c5ba733bbea4a8 SHA512 7740742abfd6521f22d3281c0df882905c89af9ff673bf8da38d8503ef9f3853dbfc467f979e3057c7813f1fbf971a7369913a3f6b6ebe2fa87391bc30d606db
diff --git a/sys-kernel/git-sources/git-sources-6.2_rc6.ebuild b/sys-kernel/git-sources/git-sources-6.2_rc6.ebuild
new file mode 100644
index 000000000000..3361401fba57
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.2_rc6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}