summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-02-20 18:35:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-02-20 18:36:26 +0200
commitb5e1fd69d6a699d83c8de0a9cce8e4ef97e90cb4 (patch)
tree932356bca23f53fd21377ff9f12ab2a172aeeaa7 /sys-kernel
parentdev-ml/tyxml: Version bump to 4.2.0 (diff)
downloadgentoo-b5e1fd69d6a699d83c8de0a9cce8e4ef97e90cb4.tar.gz
gentoo-b5e1fd69d6a699d83c8de0a9cce8e4ef97e90cb4.tar.bz2
gentoo-b5e1fd69d6a699d83c8de0a9cce8e4ef97e90cb4.zip
sys-kernel/pf-sources: bump to 5.11-pf2
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.11_p2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 658a32ca2693..cd724907d29d 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -21,4 +21,5 @@ DIST pf-sources-5.10_p7.patch 4104263 BLAKE2B a53f381c255aa242955d7401496b5b21fb
DIST pf-sources-5.10_p8.patch 4232466 BLAKE2B efe977028da96031c2834af65fc7da943ad0d7d0155a54e614a61ae825672b147dca31491487c8bb500aac9db869e303d3ced6a30bdd9f6fdf4bf0a0d93dc9c3 SHA512 bf64e4a12627f5c0b39dba44f815d7a42758a9e0a79fb341c535ed2b64e99068c8fdc1b8e3ae6656e815280337715b2b19d084fb589a5c60a1e5ab8e2153e27a
DIST pf-sources-5.10_p9.patch 4509136 BLAKE2B a0bd46d0e6f833849736da492e89fbc3885bf3b96db0f1cbd03525e5d60a2a8f224851f92c73f51224565ba27517ab3310af8b853fa03fedc55d8f035bda0389 SHA512 45ad1097dc270a347be598c053bc19d0a830f86e124e317c5bdf3682ed41c523ed80d277ae94ca6ecee247792254b8f16b9c9ad5c90288dec9ab6d4cb5f0d272
DIST pf-sources-5.11_p1.patch 2710131 BLAKE2B 67a3528d1c59f24af9f09bc669e736d41394041874e07ebaa68bba8393d98b6094f3c733f1f395cb0a816f418702934d7ac828fceabebcec187526ca378929f4 SHA512 0bc79a5eb093c0b072826098b78894d59bab2bb8107221c9727c4aebb839b2e4d066c2f4918614bfbf4e3af210a6d1852189303f9ebf338f2e5038f166d4dfb0
+DIST pf-sources-5.11_p2.patch 2720760 BLAKE2B db2ccb4449d6ed2d545c15ef82b99d581e462908ab2290b62119c09da93a7cf202e3a1792a1bf3afb6ae98f4c9f8ea34ef7ad7056206f3eac7daa8a7a9559f4a SHA512 1ab4748cac5a8a210a48543606c2c3e30e4528c819b4e7d7e29d992d4f9b14ae6e7219d7d96d090fc887d72887735e52dad9a8d396d775c8c32b80b01532a9ea
DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.11_p2.ebuild b/sys-kernel/pf-sources/pf-sources-5.11_p2.ebuild
new file mode 100644
index 000000000000..223e79a03a51
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.11_p2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}