summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-23 15:05:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-23 15:06:02 +0200
commitdeeee63ae23debdc59584cb9e2e25ee2d87751b5 (patch)
tree769dd6f5aebcad9f6698077cce459ce1b31d2a59 /sys-libs/libblockdev
parentsys-libs/libblockdev: Removed old (diff)
downloadgentoo-deeee63ae23debdc59584cb9e2e25ee2d87751b5.tar.gz
gentoo-deeee63ae23debdc59584cb9e2e25ee2d87751b5.tar.bz2
gentoo-deeee63ae23debdc59584cb9e2e25ee2d87751b5.zip
sys-libs/libblockdev: Don't build with "-Werror" by default
Closes: https://bugs.gentoo.org/744289 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libblockdev')
-rw-r--r--sys-libs/libblockdev/libblockdev-2.24.ebuild11
-rw-r--r--sys-libs/libblockdev/libblockdev-9999.ebuild11
2 files changed, 16 insertions, 6 deletions
diff --git a/sys-libs/libblockdev/libblockdev-2.24.ebuild b/sys-libs/libblockdev/libblockdev-2.24.ebuild
index 2d41db827580..04aa60d48088 100644
--- a/sys-libs/libblockdev/libblockdev-2.24.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.24.ebuild
@@ -4,12 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1 xdg-utils
+inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
HOMEPAGE="https://github.com/storaged-project/libblockdev"
if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
BDEPEND="
sys-devel/autoconf-archive
@@ -73,7 +73,12 @@ pkg_setup() {
src_prepare() {
xdg_environment_reset #623992
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ # https://bugs.gentoo.org/744289
+ find -type f \( -name "Makefile.am" -o -name "configure.ac" \) -print0 \
+ | xargs --null sed "s@ -Werror@@" -i || die
+
+ eautoreconf
}
src_configure() {
diff --git a/sys-libs/libblockdev/libblockdev-9999.ebuild b/sys-libs/libblockdev/libblockdev-9999.ebuild
index 214de07c57c9..1ad37598e5fe 100644
--- a/sys-libs/libblockdev/libblockdev-9999.ebuild
+++ b/sys-libs/libblockdev/libblockdev-9999.ebuild
@@ -4,12 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1 xdg-utils
+inherit autotools python-single-r1 xdg-utils
DESCRIPTION="A library for manipulating block devices"
HOMEPAGE="https://github.com/storaged-project/libblockdev"
if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/storaged-project/libblockdev.git"
BDEPEND="
sys-devel/autoconf-archive
@@ -73,7 +73,12 @@ pkg_setup() {
src_prepare() {
xdg_environment_reset #623992
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ # https://bugs.gentoo.org/744289
+ find -type f \( -name "Makefile.am" -o -name "configure.ac" \) -print0 \
+ | xargs --null sed "s@ -Werror@@" -i || die
+
+ eautoreconf
}
src_configure() {