summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-24 01:41:08 +0000
committerSam James <sam@gentoo.org>2023-12-24 01:45:07 +0000
commit3f94f64e9243db42bda7a418edb8008b6acb4fc5 (patch)
tree4109edb574be57e6381edc743a81e96cba882c8a /sys-libs/libcap-ng
parentsys-libs/timezone-data: add 2023d (diff)
downloadgentoo-3f94f64e9243db42bda7a418edb8008b6acb4fc5.tar.gz
gentoo-3f94f64e9243db42bda7a418edb8008b6acb4fc5.tar.bz2
gentoo-3f94f64e9243db42bda7a418edb8008b6acb4fc5.zip
sys-libs/libcap-ng: add 0.8.4
Note that this drops the workaround for bug #759550 - as the upstream maintainer has done in Fedora too [0] [0] https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/A4NEVRDJLLLOK5LLLTQC7Y2HS3MVAWQM/ Bug: https://bugs.gentoo.org/759550 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libcap-ng')
-rw-r--r--sys-libs/libcap-ng/Manifest1
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.8.4.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/Manifest b/sys-libs/libcap-ng/Manifest
index 45b492af66d5..0ffa199c4537 100644
--- a/sys-libs/libcap-ng/Manifest
+++ b/sys-libs/libcap-ng/Manifest
@@ -1,2 +1,3 @@
DIST libcap-ng-0.8.2-apply-disable.patch 723 BLAKE2B 70d9959c55119c02bbc4ea605251491c04c477511c20b9fe93e6527ffd3fe2f35a72fabab5ca149c4aaf536c6cd8dceb15375297158f8827a0c676744381bbc1 SHA512 8c9317bdd4fde7d6a4618ec613bce46bed7646891bd16bc3fa307e9a814e38601bf3c6ad13102389d4596d9ed6a7ad853cca58624e724fe07383007e386c51f8
DIST libcap-ng-0.8.3.tar.gz 455383 BLAKE2B c54dd753e0ef6dd21bcf6af7b003f85ded9faf2fbf1ea834cda6b181b165ff4b11a0284c23c73d0e6f97a810b3e6a63fceeb57ff583a2b32f23924bdee597ef5 SHA512 0ef9bc7bc6b7b59991f43b79aa6cde3e8d2c22c4b9ced2af8deae501e01d51e893033d109cb8aa0fdcba190140110993089245346334d7b114d18f1bb1b55b97
+DIST libcap-ng-0.8.4.tar.gz 453749 BLAKE2B 523480281cfa544e77e30932968b4b18424286dbced06bb4645d536cf19d4cc0f7c73de82006ffc329aa7ef208e0cf8e3379f1b20e1e8e4e90e422ed736f6c44 SHA512 f4f3499d592e8583c2bdb8d700981a7930bd545f0889bc02f49acecf17e3bc600b100cd4f64e9326e5bac0a07a02a1ac4b7e83e919563066665a3d67cbe6871e
diff --git a/sys-libs/libcap-ng/libcap-ng-0.8.4.ebuild b/sys-libs/libcap-ng/libcap-ng-0.8.4.ebuild
new file mode 100644
index 000000000000..610a3467043c
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.8.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Keep an eye on Fedora's packaging (https://src.fedoraproject.org/rpms/libcap-ng/tree/rawhide) for patches
+# Same maintainer in Fedora as upstream
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+BDEPEND="python? ( >=dev-lang/swig-2 )"
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ sed -i "s@cat /usr@cat ${EPREFIX}/usr@" bindings/python*/Makefile.am || die
+ # bug #668722
+ eautomake
+ fi
+}
+
+src_configure() {
+ use sparc && replace-flags -O? -O0
+
+ local ECONF_SOURCE="${S}"
+
+ local myconf=(
+ $(use_enable static-libs static)
+ )
+
+ local pythonconf=(
+ --without-python3
+ )
+
+ # Set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ pythonconf=(
+ --with-python3
+ )
+
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ }
+
+ python_foreach_impl setup_python_flags_configure
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ fi
+}
+
+src_compile() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir emake
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ emake -C "${BUILD_DIR}"
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]] ; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ if use python ; then
+ python_foreach_impl run_in_build_dir emake check
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ emake -C "${BUILD_DIR}" check
+ fi
+}
+
+src_install() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}