summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2024-01-16 19:26:55 -0500
committerKenton Groombridge <concord@gentoo.org>2024-01-16 20:29:14 -0500
commitf9c83ecfad63b6c0c513399376b52acb319c43fb (patch)
treecb0f9354b211d7e5c580ecfe65f75020a7a39c80 /sys-libs/libsepol
parentsys-apps/restorecond: update live ebuild (diff)
downloadgentoo-f9c83ecfad63b6c0c513399376b52acb319c43fb.tar.gz
gentoo-f9c83ecfad63b6c0c513399376b52acb319c43fb.tar.bz2
gentoo-f9c83ecfad63b6c0c513399376b52acb319c43fb.zip
sys-libs/libsepol: bump to 3.6
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/Manifest1
-rw-r--r--sys-libs/libsepol/libsepol-3.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index cef9954d3145..aeb3b703de01 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -1 +1,2 @@
DIST libsepol-3.5.tar.gz 497522 BLAKE2B dad2d346605be53fe41aef69e2e4bd4f1ce68a15f0b9307deb6b66bbe7bf06a9ee6be580e60d2f19aebbc8ee5041ac8a7b831b51342ba7c7089e1f1a447e7691 SHA512 66f45a9f4951589855961955db686b006b4c0cddead6ac49ad238a0e4a34775905bd10fb8cf0c0ff2ab64f9b7d8366b97fcd5b19c382dec39971a2835cc765c8
+DIST libsepol-3.6.tar.gz 509100 BLAKE2B c073c9437004df0c723125971ed26354dc6b8a78b069c593977062527342061303bcc48917fcd9623d17998748254f63408b233173f3c62e92ee0ea2f3c4a430 SHA512 35a42d2749fc4f71bc6b7488380714f56975564007128566f1c73e5c50bf81c17535b2cfda4583aacb4870aa2cd5885321c01523e415bda8b3326bfefb13d58e
diff --git a/sys-libs/libsepol/libsepol-3.6.ebuild b/sys-libs/libsepol/libsepol-3.6.ebuild
new file mode 100644
index 000000000000..17fe4da89451
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs multilib-minimal
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/2"
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
+
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}