summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-10 12:03:24 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-10 12:13:08 +0100
commit63d895fc4513a2e417c3de47bd08e1f88ca4c13f (patch)
tree18e2ca422c45b9807567aabd263844be91bd1cd3 /sys-libs/llvm-libunwind
parentsys-libs/compiler-rt-sanitizers: Migrate to llvm-utils (diff)
downloadgentoo-63d895fc4513a2e417c3de47bd08e1f88ca4c13f.tar.gz
gentoo-63d895fc4513a2e417c3de47bd08e1f88ca4c13f.tar.bz2
gentoo-63d895fc4513a2e417c3de47bd08e1f88ca4c13f.zip
sys-libs/llvm-libunwind: Migrate to llvm-utils
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-18.1.0_rc2.ebuild11
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-19.0.0.9999.ebuild11
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-19.0.0_pre20240203.ebuild11
3 files changed, 12 insertions, 21 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-18.1.0_rc2.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-18.1.0_rc2.ebuild
index 73ad1389deb4..df7d3e6095bc 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-18.1.0_rc2.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-18.1.0_rc2.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
@@ -43,12 +43,9 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-pkg_setup() {
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
multilib_src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
local libdir=$(get_libdir)
# https://github.com/llvm/llvm-project/issues/56825
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0.9999.ebuild
index 73ad1389deb4..df7d3e6095bc 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
@@ -43,12 +43,9 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-pkg_setup() {
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
multilib_src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
local libdir=$(get_libdir)
# https://github.com/llvm/llvm-project/issues/56825
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0_pre20240203.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0_pre20240203.ebuild
index 73ad1389deb4..df7d3e6095bc 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0_pre20240203.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-19.0.0_pre20240203.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
@@ -43,12 +43,9 @@ python_check_deps() {
python_has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
-pkg_setup() {
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
multilib_src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
local libdir=$(get_libdir)
# https://github.com/llvm/llvm-project/issues/56825