summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-06-18 18:01:14 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-06-18 18:02:15 +0300
commitfc2e898a3615e0daf9354c0dc00e5aa5686984cc (patch)
treef78c09493df0ec381f107a1318ab0c3dc9e69e88 /sys-libs/pam
parentprofiles: Mask obsolete games with libgnomeui dependency for removal (diff)
downloadgentoo-fc2e898a3615e0daf9354c0dc00e5aa5686984cc.tar.gz
gentoo-fc2e898a3615e0daf9354c0dc00e5aa5686984cc.tar.bz2
gentoo-fc2e898a3615e0daf9354c0dc00e5aa5686984cc.zip
sys-libs/pam: go back to the manual tmpfiles creation
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-libs/pam')
-rw-r--r--sys-libs/pam/pam-1.4.0-r2.ebuild (renamed from sys-libs/pam/pam-1.4.0-r1.ebuild)15
1 files changed, 8 insertions, 7 deletions
diff --git a/sys-libs/pam/pam-1.4.0-r1.ebuild b/sys-libs/pam/pam-1.4.0-r2.ebuild
index 2217c406746f..95952e5cfb40 100644
--- a/sys-libs/pam/pam-1.4.0-r1.ebuild
+++ b/sys-libs/pam/pam-1.4.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools db-use fcaps tmpfiles toolchain-funcs usr-ldscript multilib-minimal
+inherit autotools db-use fcaps toolchain-funcs usr-ldscript multilib-minimal
DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
HOMEPAGE="https://github.com/linux-pam/linux-pam"
@@ -95,10 +95,15 @@ multilib_src_install() {
multilib_src_install_all() {
find "${ED}" -type f -name '*.la' -delete || die
- newtmpfiles - "${CATEGORY}-${PN}.conf" <<-_EOF_
+ # tmpfiles.eclass is impossible to use because
+ # there is the pam -> tmpfiles -> systemd -> pam dependency loop
+
+ dodir /usr/lib/tmpfiles.d
+
+ cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}.conf <<-_EOF_
d /run/faillock 0755 root root
_EOF_
- use selinux && newtmpfiles - "${CATEGORY}-${PN}-selinux.conf" <<-_EOF_
+ use selinux && cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}-selinux.conf <<-_EOF_
d /run/sepermit 0755 root root
_EOF_
@@ -122,8 +127,4 @@ pkg_postinst() {
# The pam_unix module needs to check the password of the user which requires
# read access to /etc/shadow only.
fcaps cap_dac_override sbin/unix_chkpwd
-
- # OpenRC systems need this processed right away
- tmpfiles_process "${CATEGORY}-${PN}.conf"
- use selinux && tmpfiles_process "${CATEGORY}-${PN}-selinux.conf"
}