summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-14 21:29:15 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-14 21:29:53 -0800
commitfb314393605d1ce7b45bf6476762bf83e793d7a3 (patch)
tree6fa20470cf6a81ed855e6b0028a9352f02def772 /virtual
parentsci-mathematics/octave: fix build loop with USE=doc & texinfo-7.0 (diff)
downloadgentoo-fb314393605d1ce7b45bf6476762bf83e793d7a3.tar.gz
gentoo-fb314393605d1ce7b45bf6476762bf83e793d7a3.tar.bz2
gentoo-fb314393605d1ce7b45bf6476762bf83e793d7a3.zip
virtual/rust: add experimental llvm-ver subslot for mozilla consumers
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.64.0-r1.ebuild22
-rw-r--r--virtual/rust/rust-1.65.0-r1.ebuild23
2 files changed, 45 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.64.0-r1.ebuild b/virtual/rust/rust-1.64.0-r1.ebuild
new file mode 100644
index 000000000000..6b38ec4b8770
--- /dev/null
+++ b/virtual/rust/rust-1.64.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-14"
+#KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"
diff --git a/virtual/rust/rust-1.65.0-r1.ebuild b/virtual/rust/rust-1.65.0-r1.ebuild
new file mode 100644
index 000000000000..8a0f09ded700
--- /dev/null
+++ b/virtual/rust/rust-1.65.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-15"
+#KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"