summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_common_redirect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_common_redirect')
-rw-r--r--www-apache/mod_common_redirect/Manifest1
-rw-r--r--www-apache/mod_common_redirect/files/20_mod_common_redirect.conf5
-rw-r--r--www-apache/mod_common_redirect/metadata.xml10
-rw-r--r--www-apache/mod_common_redirect/mod_common_redirect-0.1.1.ebuild30
4 files changed, 46 insertions, 0 deletions
diff --git a/www-apache/mod_common_redirect/Manifest b/www-apache/mod_common_redirect/Manifest
new file mode 100644
index 000000000000..41c4a0d218f6
--- /dev/null
+++ b/www-apache/mod_common_redirect/Manifest
@@ -0,0 +1 @@
+DIST mod_common_redirect-0.1.1.tar.gz 3341 SHA256 d51b48c5fd140b051055339c79719597e194f38d1cee7149ee98669772d97c23
diff --git a/www-apache/mod_common_redirect/files/20_mod_common_redirect.conf b/www-apache/mod_common_redirect/files/20_mod_common_redirect.conf
new file mode 100644
index 000000000000..f2d135e66ecd
--- /dev/null
+++ b/www-apache/mod_common_redirect/files/20_mod_common_redirect.conf
@@ -0,0 +1,5 @@
+<IfDefine COMMON_REDIRECT>
+LoadModule common_redirect_module modules/mod_common_redirect.so
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_common_redirect/metadata.xml b/www-apache/mod_common_redirect/metadata.xml
new file mode 100644
index 000000000000..7966e6e344bd
--- /dev/null
+++ b/www-apache/mod_common_redirect/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hollow/mod_common_redirect</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_common_redirect/mod_common_redirect-0.1.1.ebuild b/www-apache/mod_common_redirect/mod_common_redirect-0.1.1.ebuild
new file mode 100644
index 000000000000..0a52f4a0bae6
--- /dev/null
+++ b/www-apache/mod_common_redirect/mod_common_redirect-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit apache-module
+
+GITHUB_AUTHOR="hollow"
+GITHUB_PROJECT="mod_common_redirect"
+GITHUB_COMMIT="595a370"
+
+DESCRIPTION="mod_common_redirect implements common redirects without mod_rewrite overhead"
+HOMEPAGE="http://github.com/hollow/mod_common_redirect"
+SRC_URI="http://nodeload.github.com/${GITHUB_AUTHOR}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="COMMON_REDIRECT"
+
+need_apache2
+
+S="${WORKDIR}"/${GITHUB_AUTHOR}-${GITHUB_PROJECT}-${GITHUB_COMMIT}