summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2019-08-02 12:28:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-07 07:42:29 +0200
commit0632e600cea736adec48417e0885d3860dcd1270 (patch)
treebc94e6a8db1ae8182f2005457c796376746f1c25 /www-apps/gitea
parentmail-client/alpine: make PAM optional (diff)
downloadgentoo-0632e600cea736adec48417e0885d3860dcd1270.tar.gz
gentoo-0632e600cea736adec48417e0885d3860dcd1270.tar.bz2
gentoo-0632e600cea736adec48417e0885d3860dcd1270.zip
www-apps/gitea: bump to 1.9.5
Closes: https://bugs.gentoo.org/687148 Closes: https://bugs.gentoo.org/690838 Closes: https://bugs.gentoo.org/693536 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/files/gitea-logflags.patch13
-rw-r--r--www-apps/gitea/files/gitea-mod-vendor.patch46
-rw-r--r--www-apps/gitea/gitea-1.9.5.ebuild111
-rw-r--r--www-apps/gitea/metadata.xml7
5 files changed, 174 insertions, 4 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 131fa9008c23..9ee165318d1c 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,3 +1,4 @@
DIST gitea-1.8.0.tar.gz 24268907 BLAKE2B b46a17733fc7bd0f228620bdfadf0d596ea56fca6e685afab7734e794c1f87c5e004529ca3d69e907d516bcb83563565b1d8c32501f1c2c0f9295ca028d96ad0 SHA512 eebbe2f77ed2e4c3562f48a6fa647e6f2a0492c5b6ea4f13542a5ef82e94a357a8d53897aa013107b5f735d2aff9d719893b5724de44831c43998c2e9c6e78d7
DIST gitea-1.8.2.tar.gz 24321492 BLAKE2B 48a718edd1d607e4f8ee2a301bdd907f2a233be515fa327eac9cfb50cdbc024e5f90e6e86e95056c256cb35497c5a3b2ab5fa4a068a22b28c1a3d2b94780da7a SHA512 23ef63c1cea276800a19fe04b87b4baa421e1202260b4ec55614a77ee54c0bc9e5db6dad7f98791c4d902b2d4cb15f4facc4d201631cf2ef7cefd0ff996753be
DIST gitea-1.8.3.tar.gz 24320679 BLAKE2B 9ef901ef7e1cb6ffa9a2aa082798b7a18ac2a6fdb4379082df3f942d767a27fd3915c7a4d2cb1af6f502a8cde3c1c98557c42d4c0ef60be7bdad78d8931035e0 SHA512 f6019fbfc056e4c7176222ccaca1cf638bd1f52323de54fcddc618129aeb778674f6e305de60e7d17b69505ad65439445ee6b5e368afdf0a6fbace7407acb495
+DIST gitea-1.9.5.tar.gz 25355286 BLAKE2B 8b733651de64fcafa7b41a6fc812fcad8ac7311a7e7acc679ec7dab759175ec13a096902aece209a3fef31eefd3a99493e13f7c9792e1e41b5a1c3376680d3ca SHA512 f7a04d3bb37a33da15290355f3f02ff4c1b737e8458cf65f731c870ac9e452243b1fdacc5f74accf963fb00cdd200dd31191058eb1d6dda8b1033846a961c7d3
diff --git a/www-apps/gitea/files/gitea-logflags.patch b/www-apps/gitea/files/gitea-logflags.patch
new file mode 100644
index 000000000000..331bd3d046b1
--- /dev/null
+++ b/www-apps/gitea/files/gitea-logflags.patch
@@ -0,0 +1,13 @@
+diff --git a/modules/log/flags.go b/modules/log/flags.go
+index 992fc62..5578a1b 100644
+--- a/modules/log/flags.go
++++ b/modules/log/flags.go
+@@ -31,7 +31,7 @@ const (
+ Lmedfile = Lshortfile | Llongfile
+
+ // LstdFlags is the initial value for the standard logger
+- LstdFlags = Ldate | Ltime | Lmedfile | Lshortfuncname | Llevelinitial
++ LstdFlags = Ldate | Ltime | Llevelinitial
+ )
+
+ var flagFromString = map[string]int{
diff --git a/www-apps/gitea/files/gitea-mod-vendor.patch b/www-apps/gitea/files/gitea-mod-vendor.patch
new file mode 100644
index 000000000000..c501e20adb94
--- /dev/null
+++ b/www-apps/gitea/files/gitea-mod-vendor.patch
@@ -0,0 +1,46 @@
+diff --git a/Makefile b/Makefile
+index 796a0e3..2c6a6ef 100644
+--- a/Makefile
++++ b/Makefile
+@@ -97,7 +97,7 @@ vet:
+
+ .PHONY: generate
+ generate:
+- GO111MODULE=on $(GO) generate $(PACKAGES)
++ GO111MODULE=on $(GO) generate -mod=vendor $(PACKAGES)
+
+ .PHONY: generate-swagger
+ generate-swagger:
+diff --git a/modules/options/options.go b/modules/options/options.go
+index 723dd54..62e8c04 100644
+--- a/modules/options/options.go
++++ b/modules/options/options.go
+@@ -5,7 +5,6 @@
+ package options
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
+
+ type directorySet map[string][]string
+
+diff --git a/modules/public/public.go b/modules/public/public.go
+index 8362b42..df70275 100644
+--- a/modules/public/public.go
++++ b/modules/public/public.go
+@@ -18,7 +18,6 @@ import (
+ )
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
+
+ // Options represents the available options to configure the macaron handler.
+ type Options struct {
+diff --git a/modules/templates/templates.go b/modules/templates/templates.go
+index e7fe3b2..af6bf01 100644
+--- a/modules/templates/templates.go
++++ b/modules/templates/templates.go
+@@ -5,4 +5,3 @@
+ package templates
+
+ //go:generate go run -mod=vendor main.go
+-//go:generate go fmt bindata.go
diff --git a/www-apps/gitea/gitea-1.9.5.ebuild b/www-apps/gitea/gitea-1.9.5.ebuild
new file mode 100644
index 000000000000..5b022012714d
--- /dev/null
+++ b/www-apps/gitea/gitea-1.9.5.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit golang-vcs-snapshot tmpfiles systemd
+
+EGO_PN="code.gitea.io/gitea"
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+acct pam sqlite"
+
+BDEPEND="<dev-lang/go-1.13"
+COMMON_DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea]
+ )
+ pam? ( sys-libs/pam )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ dev-vcs/git"
+
+DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+PATCHES=( "${FILESDIR}/gitea-mod-vendor.patch" "${FILESDIR}/gitea-logflags.patch" )
+
+gitea_make() {
+ local my_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local my_makeopt=(
+ DRONE_TAG=${PV}
+ TAGS="${my_tags[@]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\""
+ )
+ GOPATH=${WORKDIR}/${P}:$(get_golibdir_gopath) emake "${my_makeopt[@]}" "$@"
+}
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^RUN_MODE = dev#RUN_MODE = prod#"
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ -e "s#^APP_ID =#;APP_ID =#"
+ -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
+ fi
+
+ gitea_make generate
+}
+
+src_compile() {
+ gitea_make build
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.ini.sample app.ini
+ if use acct ; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ ewarn "The configuration path has been changed to ${EROOT}/etc/gitea/app.ini."
+ ewarn "Please move your configuration from ${EROOT}/var/lib/gitea/conf/app.ini"
+ ewarn "and adapt the gitea-repositories hooks and ssh authorized_keys."
+ ewarn "Depending on your configuration you should run something like:"
+ ewarn "sed -i -e 's#${EROOT}/var/lib/gitea/conf/app.ini#${EROOT}/etc/gitea/app.ini#' \\"
+ ewarn " /var/lib/gitea/gitea-repositories/*/*/hooks/*/* \\"
+ ewarn " /var/lib/gitea/.ssh/authorized_keys"
+ fi
+}
diff --git a/www-apps/gitea/metadata.xml b/www-apps/gitea/metadata.xml
index df58a68c26f0..f492ced05e45 100644
--- a/www-apps/gitea/metadata.xml
+++ b/www-apps/gitea/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>xdch47@posteo.de</email>
- <name>Felix Neumärker</name>
- </maintainer>
- <maintainer type="person">
<email>nemunaire@nemunai.re</email>
<name>Pierre-Olivier Mercier</name>
</maintainer>
@@ -16,4 +12,7 @@
<upstream>
<remote-id type="github">go-gitea/gitea</remote-id>
</upstream>
+ <use>
+ <flag name="acct">User and group management via acct-*/git packages</flag>
+ </use>
</pkgmetadata>