summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-12-08 09:59:31 +0100
committerSam James <sam@gentoo.org>2020-12-15 03:53:08 +0000
commit5c23645a1cff7dfd2865639e3a0575542d31ddca (patch)
treee1f1e1a95ce190c98cb44eafdac2eda3ed7bb185 /www-apps/gitea
parentx11-misc/rofi: pkgconfig is a BDEPEND here (diff)
downloadgentoo-5c23645a1cff7dfd2865639e3a0575542d31ddca.tar.gz
gentoo-5c23645a1cff7dfd2865639e3a0575542d31ddca.tar.bz2
gentoo-5c23645a1cff7dfd2865639e3a0575542d31ddca.zip
www-apps/gitea: keep gitea-9999 sync with gitea-1.x.y
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 672af6461ca6..b92bde68e9a3 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -39,6 +39,9 @@ FILECAPS=(
cap_net_bind_service+ep usr/bin/gitea
)
+RESTRICT="test"
+QA_PRESTRIPPED="usr/bin/gitea"
+
src_prepare() {
default
@@ -114,3 +117,9 @@ src_install() {
keepdir /var/log/gitea
fi
}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ go-module_pkg_postinst
+ tmpfiles_process gitea.conf
+}