summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-04-17 11:28:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-13 10:59:43 +0300
commit9127c687a0abd0859fc051909c6b2c96ecd49fae (patch)
tree8a9264a4db6f2ec9309ad5e3446c305a5f5edace /www-apps/gitea
parentwww-apps/gitea: Add file capability to bind port 22 (diff)
downloadgentoo-9127c687a0abd0859fc051909c6b2c96ecd49fae.tar.gz
gentoo-9127c687a0abd0859fc051909c6b2c96ecd49fae.tar.bz2
gentoo-9127c687a0abd0859fc051909c6b2c96ecd49fae.zip
www-apps/gitea: bump to 1.11.5
Closes: https://bugs.gentoo.org/710996 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/15564 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.11.5.ebuild141
-rw-r--r--www-apps/gitea/metadata.xml1
3 files changed, 143 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 6a98f686f7bd..490bacf759c0 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1 +1,2 @@
DIST gitea-1.10.6.tar.gz 30147860 BLAKE2B e41e226be820eb0a436783f49bf90a1149eef4e0dde00edc09bc76bb086ea53ff2856563e31ab261e1529a03753785e04c1fe8a02f72eef01a6de173df82098d SHA512 be64f73eb0819c28e444b9dae8d4baecd910aad790efeb515a981542125679257f48a5f4ab1c8453b5372a0c8b1e9b84275e61c89dcd2137d7f7cfe8c71f917b
+DIST gitea-src-1.11.5.tar.gz 68923871 BLAKE2B 99e189b4a95e9ef6079a5e8455c05209da742499ff1b18e9f5edab2620ff8deb64ca3b7cb59d456b6fe25558602be8e1f8376ec234229c6af7baf24cc6d15023 SHA512 b12bfb2fc13bd0ca5799d52c37b5d2988879041892aa1e160546f7c80e2faef086f76cd753de90f2468fe9f87af6eca64ca21df394db160fc347137fc9a0fd52
diff --git a/www-apps/gitea/gitea-1.11.5.ebuild b/www-apps/gitea/gitea-1.11.5.ebuild
new file mode 100644
index 000000000000..44802e089f92
--- /dev/null
+++ b/www-apps/gitea/gitea-1.11.5.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} != 9999* ]] ; then
+ SCM="golang-vcs-snapshot"
+else
+ SCM="git-r3"
+fi
+
+inherit fcaps golang-base tmpfiles systemd ${SCM}
+unset SCM
+
+EGO_PN="code.gitea.io/gitea"
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io"
+
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64"
+else
+ EGIT_REPO_URI="https://github.com/go-gitea/gitea"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
+ has test ${FEATURES} && EGIT_MIN_CLONE_TYPE="mirror"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct build-client pam sqlite"
+
+BDEPEND="dev-lang/go
+ build-client? ( >=net-libs/nodejs-10[npm] )"
+DEPEND="pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ acct? (
+ acct-group/git
+ acct-user/git[gitea]
+ )
+ dev-vcs/git"
+
+DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
+FILECAPS=( cap_net_bind_service+ep usr/bin/gitea )
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+PATCHES=( "${FILESDIR}/gitea-logflags.patch" )
+
+gitea_make() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ TAGS="${gitea_tags[@]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[@]}"
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)"
+ )
+ [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${PV}")
+
+ env "${makeenv[@]}" emake -j1 "$@"
+}
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^RUN_MODE = dev#RUN_MODE = prod#"
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ -e "s#^APP_ID =#;APP_ID =#"
+ -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
+ fi
+
+ # Remove already build assets (like frontend part)
+ use build-client && gitea_make clean-all
+}
+
+src_compile() {
+ if use build-client ; then
+ gitea_make build
+ else
+ gitea_make backend
+ fi
+}
+
+src_test() {
+ if has network-sandbox ${FEATURES}; then
+ einfo "Remove tests which are known to fail with network-sandbox enabled."
+ rm ./modules/migrations/github_test.go || die
+ fi
+
+ if [[ ${PV} != 9999* ]] ; then
+ einfo "Remove tests which depend on gitea git-repo."
+ rm ./modules/git/blob_test.go || die
+ rm ./modules/git/repo_test.go || die
+ fi
+
+ default
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.ini.sample app.ini
+ if use acct ; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
diff --git a/www-apps/gitea/metadata.xml b/www-apps/gitea/metadata.xml
index f492ced05e45..61330ddff932 100644
--- a/www-apps/gitea/metadata.xml
+++ b/www-apps/gitea/metadata.xml
@@ -14,5 +14,6 @@
</upstream>
<use>
<flag name="acct">User and group management via acct-*/git packages</flag>
+ <flag name="build-client">Also build the client code, instead of getting precompiled one from archive. This requires net-libs/nodejs (that doesn't work on some architectures).</flag>
</use>
</pkgmetadata>