summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-05-12 10:31:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-13 10:59:43 +0300
commita567064eb42784daf85090b2afef53a71c0c099e (patch)
tree48efdd6d506c2a21b3090cc461ed8a39c319f089 /www-apps/gitea
parentwww-apps/gitea: build now requires npm (diff)
downloadgentoo-a567064eb42784daf85090b2afef53a71c0c099e.tar.gz
gentoo-a567064eb42784daf85090b2afef53a71c0c099e.tar.bz2
gentoo-a567064eb42784daf85090b2afef53a71c0c099e.zip
www-apps/gitea: Add file capability to bind port 22
Closes: https://bugs.gentoo.org/721956 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index ce44b1f5ef76..0d1559ca4a39 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -9,7 +9,7 @@ else
SCM="git-r3"
fi
-inherit golang-base tmpfiles systemd ${SCM}
+inherit fcaps golang-base tmpfiles systemd ${SCM}
unset SCM
EGO_PN="code.gitea.io/gitea"
@@ -41,6 +41,7 @@ RDEPEND="${DEPEND}
dev-vcs/git"
DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
+FILECAPS=( cap_net_bind_service+ep usr/bin/gitea )
S="${WORKDIR}/${P}/src/${EGO_PN}"
PATCHES=( "${FILESDIR}/gitea-logflags.patch" )