summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-12-08 10:40:42 +0100
committerSam James <sam@gentoo.org>2020-12-15 03:53:08 +0000
commitff35a72f142258f0c5b42568f9df4ac5f6482549 (patch)
tree855ff6c92141fb228936eba4e83e5ea6684b3c26 /www-apps/gitea
parentwww-apps/gitea: keep gitea-9999 sync with gitea-1.x.y (diff)
downloadgentoo-ff35a72f142258f0c5b42568f9df4ac5f6482549.tar.gz
gentoo-ff35a72f142258f0c5b42568f9df4ac5f6482549.tar.bz2
gentoo-ff35a72f142258f0c5b42568f9df4ac5f6482549.zip
www-apps/gitea: follow default upstream configuration changes
Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index b92bde68e9a3..d6f5cfcf5a8e 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -33,7 +33,7 @@ RDEPEND="${COMMON_DEPEND}
dev-vcs/git"
DOCS=(
- custom/conf/app.ini.sample CONTRIBUTING.md README.md
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
)
FILECAPS=(
cap_net_bind_service+ep usr/bin/gitea
@@ -46,7 +46,6 @@ src_prepare() {
default
local sedcmds=(
- -e "s#^RUN_MODE = dev#RUN_MODE = prod#"
-e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
-e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
-e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
@@ -55,13 +54,11 @@ src_prepare() {
-e "s#^LEVEL = Trace#LEVEL = Info#"
-e "s#^LOG_SQL = true#LOG_SQL = false#"
-e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
- -e "s#^APP_ID =#;APP_ID =#"
- -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
)
- sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
fi
einfo "Remove tests which are known to fail with network-sandbox enabled."
@@ -107,7 +104,7 @@ src_install() {
systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
insinto /etc/gitea
- newins custom/conf/app.ini.sample app.ini
+ newins custom/conf/app.example.ini app.ini
if use acct ; then
fowners root:git /etc/gitea/{,app.ini}
fperms g+w,o-rwx /etc/gitea/{,app.ini}