summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-10-31 09:30:57 -0400
committerKenton Groombridge <concord@gentoo.org>2022-10-31 09:41:06 -0400
commit4964213357a448ea6d96761951940c68299735b5 (patch)
tree837f317aae0758018a6ea163a7c2440a2b7d69a7 /www-apps/miniflux
parentnet-misc/igmpproxy: add 0.4 (diff)
downloadgentoo-4964213357a448ea6d96761951940c68299735b5.tar.gz
gentoo-4964213357a448ea6d96761951940c68299735b5.tar.bz2
gentoo-4964213357a448ea6d96761951940c68299735b5.zip
www-apps/miniflux: add 2.0.39
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'www-apps/miniflux')
-rw-r--r--www-apps/miniflux/Manifest2
-rw-r--r--www-apps/miniflux/miniflux-2.0.39.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/www-apps/miniflux/Manifest b/www-apps/miniflux/Manifest
index 5fced6ef5123..dda3cc2225e7 100644
--- a/www-apps/miniflux/Manifest
+++ b/www-apps/miniflux/Manifest
@@ -2,3 +2,5 @@ DIST miniflux-2.0.37-deps.tar.xz 154048036 BLAKE2B 88eaba31505c4d1ace55428a8e29d
DIST miniflux-2.0.37.tar.gz 555360 BLAKE2B 64188e03583dd011261c2d69c30e105af65d61ed996c4c2785621aa74d6b0602eaeed312750a089dfb1c4f5bc00c26f79549f2df27714cdca44506439b2ba6af SHA512 6944e638cdec6d0d5e92362ad4849028d0260780919eff8d6b6999327f9a482a1b3b09f1479b3c8c4b2727ced524caa13a6c7ac655b230ff244519cfe095cbd5
DIST miniflux-2.0.38-deps.tar.xz 154290660 BLAKE2B f8317e54ec3639e9bc90f9f28d4c645a816d8b8510df090145a87e9247c4762303276646505abf083d99dcf172a9a022c4771fdad58811779a47018158cd7690 SHA512 6390a6c06fb00428ff3088e81f9cca2b6343f77cc1151ccb8864eabac2983ec05630d18199b152c50fc7f463b14b7615fd901260444f00d4d6337740689d1eb3
DIST miniflux-2.0.38.tar.gz 568359 BLAKE2B 5e29663c59debdbdb4c0ed8da5d27e47ad0c0db70368844c3ede965050f0fa8410e6cd14e28faf811f39a39f0b5417d2b59302ac7cf00acfea977ab2b4b732ee SHA512 7ebedc469b8aa08e8ce73b8ae0e586927847f08e541e57fdc41b440a50524649938eb86ee56d885c688e83f1aa09063514eac4c1d8ad22459589b1ea994ef8ff
+DIST miniflux-2.0.39-deps.tar.xz 149668196 BLAKE2B ded3bcf0ac706092570d41669cbdfef68d3aab764790f3a6fd09cf8fb436765f7c10abde9422a1aa70ce31d1e186558732f8208b8a77d1ce28dc212c5e855031 SHA512 cea27e014a8d88bbd77b018d9f02736b4f7c9d39c72fa2358b581e0a01be58b9ca132d414e3c562bdaaab8c89e08a938f7b0ef94821a8a76b1025f1d7ac2a63b
+DIST miniflux-2.0.39.tar.gz 574941 BLAKE2B 66acc0c2b7bee77fd98e19c89eabcb1f7da195a18fb2b470deafd2cec23c71c3a939dde535e45fefa59e2d65b727173a59cecfda40288ee0830d23ebf5c5a1b1 SHA512 d068fd8233a235540ca232be1e36ee0fa73ea14ed0f8a8db17669bd8ddfb2d5cb35712af5ce365726e3688c6d764341c2f6d03ff8af7ae7f76e847c9f454dcb4
diff --git a/www-apps/miniflux/miniflux-2.0.39.ebuild b/www-apps/miniflux/miniflux-2.0.39.ebuild
new file mode 100644
index 000000000000..4ef790cbc12c
--- /dev/null
+++ b/www-apps/miniflux/miniflux-2.0.39.ebuild
@@ -0,0 +1,98 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Minimalist and opinionated feed reader"
+HOMEPAGE="https://miniflux.app https://github.com/miniflux/v2"
+SRC_URI="https://github.com/${PN}/v2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RESTRICT="test" # requires network access
+
+DEPEND="acct-user/miniflux"
+RDEPEND="${DEPEND}
+ >=dev-db/postgresql-9.5
+"
+
+S="${WORKDIR}/v2-${PV}"
+
+src_compile() {
+ ego build -ldflags="-s -w -X 'miniflux.app/version.Version=${PV}' " -o miniflux main.go
+}
+
+src_install() {
+ dobin miniflux
+
+ insinto /etc
+ doins "${FILESDIR}/${PN}.conf"
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners miniflux:root /etc/${PN}.conf
+ fperms o-rwx /etc/${PN}.conf
+
+ local DOCS=(
+ ChangeLog
+ README.md
+ "${FILESDIR}"/README.gentoo
+ )
+
+ # Makefile has no install target, so call einstalldocs directly
+ einstalldocs
+
+ doman "${PN}".1
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+
+ echo
+ elog "Before using miniflux, you must first create and initialize the database"
+ elog "and enable the hstore extension for it."
+ elog ""
+ elog "Afterwards, create your first admin user by running:"
+ elog " miniflux -create-admin"
+ else
+ # This is an existing installation
+
+ echo
+ elog "If you are upgrading from a previous version, schema migrations must be performed."
+ elog "To perform the migrations, stop the daemon, backup your database, and run:"
+ elog " emerge --config =${PF}"
+ fi
+
+ echo
+ elog "Please read"
+ elog ""
+ elog " ${EPREFIX}/usr/share/doc/${PF}/README.gentoo*"
+ elog ""
+ elog "for more information."
+}
+
+pkg_config() {
+ # To be safe, avoid doing migrations if miniflux is running
+ if pgrep miniflux; then
+ die "miniflux appears to be running, refusing to continue."
+ fi
+
+ # Extract the database URL variable instead of just sourcing the config file
+ # because miniflux itself may interpret quotes as part of the URL
+ local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' ${EROOT}/etc/${PN}.conf)"
+ [[ -n "${DATABASE_URL}" ]] || die "Failed getting DATABASE_URL from config file"
+
+ DATABASE_URL="${DATABASE_URL}" "${EROOT}"/usr/bin/miniflux -migrate || die "miniflux -migrate failed. Please check the above output for errors."
+
+ echo
+ elog "Database migrations complete."
+}