summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-11-06 13:31:13 -0500
committerKenton Groombridge <concord@gentoo.org>2023-11-06 13:32:45 -0500
commitad5fb9992f649b1b96ab0e5881d96664c0755155 (patch)
treebc3669b4e44eb5cd05b93f9f508d6f69d63fa1c4 /www-apps/miniflux
parentwww-apps/miniflux: stabilize 2.0.45 for amd64, ppc64 (diff)
downloadgentoo-ad5fb9992f649b1b96ab0e5881d96664c0755155.tar.gz
gentoo-ad5fb9992f649b1b96ab0e5881d96664c0755155.tar.bz2
gentoo-ad5fb9992f649b1b96ab0e5881d96664c0755155.zip
www-apps/miniflux: drop 2.0.44
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'www-apps/miniflux')
-rw-r--r--www-apps/miniflux/Manifest2
-rw-r--r--www-apps/miniflux/miniflux-2.0.44.ebuild107
2 files changed, 0 insertions, 109 deletions
diff --git a/www-apps/miniflux/Manifest b/www-apps/miniflux/Manifest
index f2ed94d0a483..5169c94d3eb0 100644
--- a/www-apps/miniflux/Manifest
+++ b/www-apps/miniflux/Manifest
@@ -1,5 +1,3 @@
-DIST miniflux-2.0.44-deps.tar.xz 38348604 BLAKE2B 6709ad503ec64ea64fb35624ff0f6d641a6ccac78d52469a0a6c6e905e505c78866603f310e82c5ff7e1bcd7656cb0d9b3516bb9d0822d7a3f8bbbdadaff0aca SHA512 f463a5a63c5611e8b90ebf15127e05e2df878bb6c49a347f182c5df40feea7e0b2fa21cff4c92b6a99f82e8be4cbd113999f0b3ba6187897af9fad49c9a2aecb
-DIST miniflux-2.0.44.tar.gz 574354 BLAKE2B a0c29cb88d88584619e6890a01af15d7b7d9a6ab230b60d76c01d95e82c5ef665aeb19f120180bc328ef3847cae2c87096a096e8f0d0455f7694539556453e5b SHA512 6c1057bcb4daf3110a8885363e2386c6d68776e917f0277299ab94fb46553a8a1b3acf4a2893ab03d30e2b3c26118257e68a7f33d5d436884bfafd8e06fc5e0a
DIST miniflux-2.0.45-deps.tar.xz 38551640 BLAKE2B b4dfe2c8bb4d96ba9b4adcb23078b7555115fed8ac346c47411fe406b086330e12f62ca71162d7eab6e1564ae21d1330d93e6e56fde8c421ff8df56cb3ca520a SHA512 79a659660daa01b2909a2e726dc37a789645a3e42c9132ad0e6cc7dd38ae08ad42075339da729fc5942e456fcb5037a414d26952731497586f322c9073f39872
DIST miniflux-2.0.45.tar.gz 580517 BLAKE2B 804c109a7cda5cd4aa4a65130b70c4d1ebb00decbdbb15c6175e14726aa1d0944d9803898e8ace8bdca083e4668f1fe2230a588793082b63967ef11d7e68827f SHA512 f2770105b05251d8ec1cd63fc8fde4ac45ba6d734c2bd96b574a4c0e33b6a9c8ce67af48d9adb29794a292c47f2f7059fea8a6e20708d0fefa6de4cbaa647328
DIST miniflux-2.0.49-deps.tar.xz 38155476 BLAKE2B 9631c23af181cf86bd197066a453c84b09840cc71a870eba0ad4e7cdb2720fe952fca7f6a93f3e9e2e2d8c9a13629da0f758b21a4afe5849186d653b44a3f097 SHA512 c51228a3f70d73788be63ed5e7f24baeee9a369351e07bd7715a60c6b340d3e90ebd25adfb50d3e2144a8b0c7d609fca3bacdd51a1d61ff7916e6a7a439b6dc1
diff --git a/www-apps/miniflux/miniflux-2.0.44.ebuild b/www-apps/miniflux/miniflux-2.0.44.ebuild
deleted file mode 100644
index 4e238162adbc..000000000000
--- a/www-apps/miniflux/miniflux-2.0.44.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module systemd
-
-# Get with 'git rev-parse --short HEAD'
-MY_GIT_COMMIT="4c0c6581"
-
-DESCRIPTION="Minimalist and opinionated feed reader"
-HOMEPAGE="https://miniflux.app https://github.com/miniflux/v2"
-SRC_URI="https://github.com/${PN}/v2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc64 ~riscv"
-
-RESTRICT="test" # requires network access
-
-DEPEND="acct-user/miniflux"
-RDEPEND="${DEPEND}
- >=dev-db/postgresql-9.5
-"
-
-S="${WORKDIR}/v2-${PV}"
-
-src_compile() {
- ego build -ldflags="
- -s -w
- -X 'miniflux.app/version.Version=${PV}'
- -X 'miniflux.app/version.Commit=${MY_GIT_COMMIT}'
- -X 'miniflux.app/version.BuildDate=$(date +%FT%T%z)'
- " -o miniflux main.go
-}
-
-src_install() {
- dobin miniflux
-
- insinto /etc
- doins "${FILESDIR}/${PN}.conf"
-
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-
- newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- fowners miniflux:root /etc/${PN}.conf
- fperms o-rwx /etc/${PN}.conf
-
- local DOCS=(
- ChangeLog
- README.md
- "${FILESDIR}"/README.gentoo
- )
-
- # Makefile has no install target, so call einstalldocs directly
- einstalldocs
-
- doman "${PN}".1
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
-
- echo
- elog "Before using miniflux, you must first create and initialize the database"
- elog "and enable the hstore extension for it."
- elog ""
- elog "Afterwards, create your first admin user by running:"
- elog " miniflux -create-admin"
- else
- # This is an existing installation
-
- echo
- elog "If you are upgrading from a previous version, schema migrations must be performed."
- elog "To perform the migrations, stop the daemon, backup your database, and run:"
- elog " emerge --config =${PF}"
- fi
-
- echo
- elog "Please read"
- elog ""
- elog " ${EPREFIX}/usr/share/doc/${PF}/README.gentoo*"
- elog ""
- elog "for more information."
-}
-
-pkg_config() {
- # To be safe, avoid doing migrations if miniflux is running
- if pgrep miniflux; then
- die "miniflux appears to be running, refusing to continue."
- fi
-
- # Extract the database URL variable instead of just sourcing the config file
- # because miniflux itself may interpret quotes as part of the URL
- local DATABASE_URL="$(sed -n 's/^DATABASE_URL=\(.*\)/\1/p' "${EROOT}/etc/${PN}.conf")"
- [[ -n "${DATABASE_URL}" ]] || die "Failed getting DATABASE_URL from config file"
-
- DATABASE_URL="${DATABASE_URL}" "${EROOT}"/usr/bin/miniflux -migrate \
- || die "miniflux -migrate failed. Please check the above output for errors."
-
- echo
- elog "Database migrations complete."
-}