summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-10 13:48:08 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-10 13:58:39 +0200
commita875556eae6fc0fb4fecd53fe3ad89fb9f369e88 (patch)
treeab67b0443f579f46600da8f248c748056ab20cb1 /www-apps/nextcloud
parentnet-analyzer/sngrep: Backport tinfo patch (diff)
downloadgentoo-a875556eae6fc0fb4fecd53fe3ad89fb9f369e88.tar.gz
gentoo-a875556eae6fc0fb4fecd53fe3ad89fb9f369e88.tar.bz2
gentoo-a875556eae6fc0fb4fecd53fe3ad89fb9f369e88.zip
www-apps/nextcloud: 19.0.0 major version bump
Closes: https://bugs.gentoo.org/727734 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/nextcloud')
-rw-r--r--www-apps/nextcloud/Manifest1
-rw-r--r--www-apps/nextcloud/nextcloud-19.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index 75b3e080aa72..437b5733c82c 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -4,3 +4,4 @@ DIST nextcloud-17.0.5.tar.bz2 66618876 BLAKE2B 9d7aabafadc768e72f90180fb0763a161
DIST nextcloud-17.0.6.tar.bz2 66599870 BLAKE2B dd4c66fcdb8c2aca978ebc1df52970cda189e56b3e48465e5a1ce9191a2e6499cc069910ef894699d9e888206335e5ac59cc813b0f2108cd585e776f88f0e333 SHA512 e97f74d2890815742654af8c3248ae8378f7d8fe57c13657824354cdd90d4a30b99dd2249980b885ec73eaba9d2ed0c1fdc9254f926f3de26f1c2832e36e9344
DIST nextcloud-18.0.3.tar.bz2 86636651 BLAKE2B ad73d397dfd8ceaa5b1edc42031a350560fd80c0c55500cff5e394f3a0ffedc0c02a5a0bbdb4579fba2765fe542cae6e8c835c2f6e07755ec368556d207cdecd SHA512 b1f433dee2e7eea800de8cd8131332530050b6194460a397081a134f63b236f65e33758c60cd8e97a43570d0b6a1baac9e0503535d85a9a34cd63abd50041292
DIST nextcloud-18.0.4.tar.bz2 86677670 BLAKE2B 57675e71a50bffc3953cb41095e41fd5a3ac30c680097fcaded34db40dc8de4b972c1c751da39b2eb500d6a3ea4dba081058b9cda52a1ad3d2dd600d9a55592f SHA512 c9754562153fdb07e0c65d5cc9749871c875a455051cd632403c31b8cb52540b95f3fdf5ba3146d65a175508580b6f3c72d3ac86a90b060baafbca1225dbba95
+DIST nextcloud-19.0.0.tar.bz2 90077143 BLAKE2B cbffdda9dcf08209f09ca05071d3f27f97fb0b333298ed72f4c71939e2b43657c957f21cf27c0acdcc9aa325e04977262297bc9620bc515eb0343bb105546d22 SHA512 ac98083887ed59a3cf1003773c46270ba03ad631c4b1ed3608a3de349ecaaf32b9e084307d19bf67956d258fbf7acbe8739f32d34ce07db3c518a9bf5f50aa0d
diff --git a/www-apps/nextcloud/nextcloud-19.0.0.ebuild b/www-apps/nextcloud/nextcloud-19.0.0.ebuild
new file mode 100644
index 000000000000..de1b7898efdf
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-19.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}