summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorscardracs <marco@scardovi.com>2021-03-27 13:52:13 +0100
committerSam James <sam@gentoo.org>2021-03-27 16:42:27 +0000
commitd9a66fab5eecfcdab4730e5164957c939741fcf8 (patch)
treea80d3fd3a1f355b11e7ef50d35cab5d2afdffa35 /www-apps/radicale
parentx11-themes/windowmaker-themes: fix USE=offensive (diff)
downloadgentoo-d9a66fab5eecfcdab4730e5164957c939741fcf8.tar.gz
gentoo-d9a66fab5eecfcdab4730e5164957c939741fcf8.tar.bz2
gentoo-d9a66fab5eecfcdab4730e5164957c939741fcf8.zip
www-apps/radicale: bump to 3.0.6
Bumped to new version and added dev-python/defusedxml as RDEPEND. Tested against python3.8/3.9 and gcc10. Not tested with musl. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Marco Scardovi <marco@scardovi.com> Closes: https://github.com/gentoo/gentoo/pull/20143 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps/radicale')
-rw-r--r--www-apps/radicale/Manifest1
-rw-r--r--www-apps/radicale/files/radicale-r2.init.d2
-rw-r--r--www-apps/radicale/metadata.xml23
-rw-r--r--www-apps/radicale/radicale-3.0.6.ebuild73
4 files changed, 90 insertions, 9 deletions
diff --git a/www-apps/radicale/Manifest b/www-apps/radicale/Manifest
index 9147cf28c9ac..158b1ea3b9c0 100644
--- a/www-apps/radicale/Manifest
+++ b/www-apps/radicale/Manifest
@@ -1 +1,2 @@
DIST Radicale-2.1.12.tar.gz 109781 BLAKE2B 743eaeffab43f2efcfc798f84d00fee40a09609beeb555e3afe3c9f4c54d8e0ce3a7eba4c1e14d6702775ab7d156b085408ee968b0d53437982cf2ea7cb4653c SHA512 a708fb1269f7ba8c9e351e101f613a8adb18c12b1239b832ed9e0287476f30aa7ded30f9bc259da9c4b5f3aefe90bbf9980d0d08d98dd07b79cd19930b0e204c
+DIST radicale-3.0.6.tar.gz 123817 BLAKE2B fa4b70c9920d518df6c939395eca857c237a75218b90ada45564f2d84266d65df12898e4efbb52905829948061e10e72b5442943fd5061a28447330ae8d491e8 SHA512 e9741547395fae8886ad84b6807422ebb196f5293d484f5f6136498058576cff697e28c117216f151d56494af83593347ceee40a6efa21272b803d0f301a396d
diff --git a/www-apps/radicale/files/radicale-r2.init.d b/www-apps/radicale/files/radicale-r2.init.d
index 00f85d29e0e5..6e7d734ebeff 100644
--- a/www-apps/radicale/files/radicale-r2.init.d
+++ b/www-apps/radicale/files/radicale-r2.init.d
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
PIDFILE=/run/radicale.pid
diff --git a/www-apps/radicale/metadata.xml b/www-apps/radicale/metadata.xml
index 6d1efe9490ca..a62d044f7fd6 100644
--- a/www-apps/radicale/metadata.xml
+++ b/www-apps/radicale/metadata.xml
@@ -1,12 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">Radicale</remote-id>
- </upstream>
- <use>
- <flag name="bcrypt">Depend on passlib to enable bcrypt and md5 authentication methods</flag>
- </use>
+ <maintainer type="person" proxied="yes">
+ <email>marco@scardovi.com</email>
+ <name>Marco Scardovi</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">Radicale</remote-id>
+ </upstream>
+ <use>
+ <flag name="bcrypt">Depend on passlib to enable bcrypt and md5 authentication methods</flag>
+ </use>
</pkgmetadata>
diff --git a/www-apps/radicale/radicale-3.0.6.ebuild b/www-apps/radicale/radicale-3.0.6.ebuild
new file mode 100644
index 000000000000..9f3474642923
--- /dev/null
+++ b/www-apps/radicale/radicale-3.0.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 eutils systemd
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="https://radicale.org/"
+SRC_URI="https://github.com/Kozea/Radicale/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+bcrypt"
+
+MY_P="Radicale-${PV}"
+
+RDEPEND="
+ acct-user/radicale
+ acct-group/radicale
+ dev-python/defusedxml
+ >=dev-python/vobject-0.9.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ bcrypt? ( dev-python/passlib[bcrypt,${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+RDIR=/var/lib/${PN}
+
+python_install_all() {
+ rm README* || die
+
+ # init file
+ newinitd "${FILESDIR}"/radicale-r2.init.d radicale
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ # directories
+ keepdir ${RDIR}
+ fowners ${PN}:${PN} ${RDIR}
+ fperms 0750 ${RDIR}
+
+ # config file
+ insinto /etc/${PN}
+ doins config
+
+ # fcgi and wsgi files
+ exeinto /usr/share/${PN}
+ doexe radicale.wsgi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ local _erdir="${EROOT}${RDIR}"
+
+ einfo "A sample WSGI script has been put into ${EROOT}/usr/share/${PN}."
+ einfo "You will also find there an example FastCGI script."
+ if [[ $(stat --format="%U:%G:%a" "${_erdir}") != "${PN}:${PN}:750" ]]
+ then
+ ewarn "Unsafe file permissions detected on ${_erdir}. This probably comes"
+ ewarn "from an earlier version of this ebuild."
+ ewarn "To fix run:"
+ ewarn " \`chown -R ${PN}:${PN} ${_erdir}\`"
+ ewarn " \`chmod 0750 ${_erdir}\`"
+ ewarn " \`chmod -R o= ${_erdir}\`"
+ fi
+}