summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-05-08 21:20:43 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-05-09 07:49:28 +0300
commit378ab19f8df52b73912c8c59c192d32a0ab2c1aa (patch)
treef737cfb1919f111f4c0d158409738f8df6998608 /www-apps/rutorrent
parentapp-containers/aardvark-dns: new package, add 1.6.0 (diff)
downloadgentoo-378ab19f8df52b73912c8c59c192d32a0ab2c1aa.tar.gz
gentoo-378ab19f8df52b73912c8c59c192d32a0ab2c1aa.tar.bz2
gentoo-378ab19f8df52b73912c8c59c192d32a0ab2c1aa.zip
www-apps/rutorrent: bump version to 4.1.5
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/30941 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/rutorrent')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-4.1.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index bbf5af16bff6..ac241e090e72 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST rutorrent-4.0.2.tar.gz 2221825 BLAKE2B 96867dbd818949388dedbfeee80ae85d22c9f3b04636d66797a96fc7b1de7541128445a989f642d711bd93aaf0840b56fe4e7bb7f29a02d122d939039eeff835 SHA512 f1f3cf7712246c02c73753e5ec8c3b5c0af4797699adeabc59822c165d06d7291d50a2d065b2d729273f907e1ec288391b1f02bc733a2b40d3e818a2de983528
DIST rutorrent-4.1.3.tar.gz 2248878 BLAKE2B 08c5a4580fbc1873b64e211cce5d0f2a92daa90bfdbc7900c7a4cfb24e5d2202afb87f6809e36191f8cbc08fd7a037eb63a4609e7c3c07d301b19a5cb2c28dc7 SHA512 c9f941bddc9759de1b183bfb9bb9eb91e91477409fc475f4585cdd90d24aeefe5e56aefa6ae45ed84bee369b4cc51f5bca64b07f8624d48246b6bc82aaaee9fb
+DIST rutorrent-4.1.5.tar.gz 2248742 BLAKE2B c79b7402cb0d9ac6fd8a26ebc22565bca8236fcb06b11dae065907955c09a6958581f4775abec774f1e968f4df381166e6e4b63a109550967f8089529977f9d8 SHA512 a0ffe258bd05b1e778b95c0bad6f76750329cd61c3086f923204fd7e404cd2a5ca8e1e93c7e863be89f093a9a10dda5a4871880582f4c77996a373cd66ff29b6
diff --git a/www-apps/rutorrent/rutorrent-4.1.5.ebuild b/www-apps/rutorrent/rutorrent-4.1.5.ebuild
new file mode 100644
index 000000000000..f7dbb6ae40d3
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.1.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}