summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-08-10 16:43:57 -0500
committerBen Kohler <bkohler@gentoo.org>2020-08-10 16:48:11 -0500
commit9a35ee7dd0736248dcddd01b6e4d6d77123285ab (patch)
tree0848852f6764538c7b6fd3ba2a68dae7438404aa /www-client
parentdev-lang/perl: Add dependency on libcrypt (diff)
downloadgentoo-9a35ee7dd0736248dcddd01b6e4d6d77123285ab.tar.gz
gentoo-9a35ee7dd0736248dcddd01b6e4d6d77123285ab.tar.bz2
gentoo-9a35ee7dd0736248dcddd01b6e4d6d77123285ab.zip
www-client/links: bump to 2.21
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/links/Manifest1
-rw-r--r--www-client/links/links-2.21.ebuild171
2 files changed, 172 insertions, 0 deletions
diff --git a/www-client/links/Manifest b/www-client/links/Manifest
index 89ed4a5ae224..1ae4993c74c3 100644
--- a/www-client/links/Manifest
+++ b/www-client/links/Manifest
@@ -1 +1,2 @@
DIST links-2.20.2.tar.bz2 6474383 BLAKE2B c69c421a85114b3dc0d7f2b37ce5454655b426ea9463c80e4a826f02374c0740d963251b4e9ed6c960dcad15403511c33f3a2e199a728e8f5425a359963bd102 SHA512 82be459856f49f45c9b824589b78c0f58b039b09802e077420053e9449bc1ded272bb8ad57ea10522d8b3305ceb212a5dd08b01052538cd5b4f0447d0ba02152
+DIST links-2.21.tar.bz2 6491465 BLAKE2B a60d2fbd252b97ead45e451c1d1d16204a23e618a59016c6b46a56b7c2f96189d3d7f71e9d647f188824ad7e7c36fd8d62dac3c7125eb9cf833591a6ce3206e6 SHA512 11fd523d0aa102d8160957bdbd36674a621aeb2e33237f0df35dcc3fad92ec288acd31dc2e7542717406047165f1249d68972c77cdb27fda076645636a056da8
diff --git a/www-client/links/links-2.21.ebuild b/www-client/links/links-2.21.ebuild
new file mode 100644
index 000000000000..0c528094f163
--- /dev/null
+++ b/www-client/links/links-2.21.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools desktop xdg-utils
+
+DESCRIPTION="A fast and lightweight web browser running in both graphics and text mode"
+HOMEPAGE="http://links.twibright.com/"
+SRC_URI="http://${PN}.twibright.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli bzip2 fbcon freetype gpm ipv6 jpeg libevent libressl livecd lzip lzma ssl suid svga tiff unicode X zlib zstd"
+
+GRAPHICS_DEPEND="media-libs/libpng:0="
+
+RDEPEND="
+ brotli? (
+ app-arch/brotli
+ )
+ bzip2? (
+ app-arch/bzip2
+ )
+ fbcon? (
+ ${GRAPHICS_DEPEND}
+ )
+ freetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ gpm? (
+ sys-libs/gpm
+ )
+ jpeg? (
+ virtual/jpeg:0
+ )
+ libevent? (
+ dev-libs/libevent:0=
+ )
+ livecd? (
+ ${GRAPHICS_DEPEND}
+ sys-libs/gpm
+ virtual/jpeg:0
+ )
+ lzip? (
+ app-arch/lzip
+ )
+ lzma? (
+ app-arch/xz-utils
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ svga? (
+ ${GRAPHICS_DEPEND}
+ media-libs/svgalib
+ )
+ tiff? (
+ media-libs/tiff:0
+ )
+ X? (
+ ${GRAPHICS_DEPEND}
+ x11-libs/libXext
+ )
+ zlib? (
+ sys-libs/zlib
+ )
+ zstd? (
+ app-arch/zstd
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ fbcon? ( virtual/os-headers )
+ livecd? ( virtual/os-headers )
+ X? ( dev-util/desktop-file-utils )"
+
+REQUIRED_USE="!livecd? ( fbcon? ( gpm ) )
+ svga? ( suid )"
+
+DOCS=( AUTHORS BRAILLE_HOWTO ChangeLog KEYS NEWS README SITES )
+
+PATCHES=( "${FILESDIR}/swap-echo-for-printf.patch" )
+
+src_prepare() {
+ use X && xdg_environment_reset
+
+ if use unicode; then
+ pushd intl > /dev/null || die
+ ./gen-intl || die
+ ./synclang || die
+ popd > /dev/null || die
+ fi
+
+ # error: conditional "am__fastdepCXX" was never defined (for eautoreconf)
+ sed -i \
+ -e '/AC_PROG_CXX/s:dnl ::' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ configure.in || die #467020
+
+ # Upstream configure produced by broken autoconf-2.13. This also fixes
+ # toolchain detection.
+ mv configure.in configure.ac || die
+
+ default
+ eautoreconf #131440 and #103483#c23
+}
+
+src_configure() {
+ local myconf
+
+ if use livecd; then
+ export ac_cv_lib_gpm_Gpm_Open=yes
+ myconf+=' --with-fb --with-libjpeg'
+ else
+ export ac_cv_lib_gpm_Gpm_Open=$(usex gpm)
+ fi
+
+ if use X || use fbcon || use svga || use livecd; then
+ myconf+=' --enable-graphics'
+ fi
+
+ econf \
+ --without-directfb \
+ --without-librsvg \
+ $(use_with brotli) \
+ $(use_with bzip2) \
+ $(use_with fbcon fb) \
+ $(use_with freetype) \
+ $(use_with ipv6) \
+ $(use_with jpeg libjpeg) \
+ $(use_with libevent) \
+ $(use_with lzip) \
+ $(use_with lzma) \
+ $(use_with ssl) \
+ $(use_with svga svgalib) \
+ $(use_with tiff libtiff) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ $(use_with zstd) \
+ ${myconf}
+}
+
+src_install() {
+ HTML_DOCS="doc/links_cal/*"
+ default
+
+ if use X; then
+ newicon Links_logo.png links.png
+ make_desktop_entry 'links -g %u' Links links 'Network;WebBrowser'
+ local d="${ED}"/usr/share/applications
+ echo 'MimeType=x-scheme-handler/http;' >> "${d}"/*.desktop || die
+ if use ssl; then
+ sed -i -e 's:x-scheme-handler/http;:&x-scheme-handler/https;:' \
+ "${d}"/*.desktop || die
+ fi
+ fi
+
+ use suid && fperms 4755 /usr/bin/links
+}
+
+pkg_postinst() {
+ use X && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ use X && xdg_desktop_database_update
+}