summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-09-22 18:04:46 -0700
committerMatt Turner <mattst88@gentoo.org>2020-09-22 18:08:15 -0700
commit9c8bb32642e9abbf92c99db0a69409e860b6c23f (patch)
tree4d3b003c2f894f7c638612703b21542ecbfcc205 /x11-drivers
parentmedia-libs/mesa: Version bump to 20.1.8 (diff)
downloadgentoo-9c8bb32642e9abbf92c99db0a69409e860b6c23f.tar.gz
gentoo-9c8bb32642e9abbf92c99db0a69409e860b6c23f.tar.bz2
gentoo-9c8bb32642e9abbf92c99db0a69409e860b6c23f.zip
x11-drivers/xf86-video-vesa: Version bump to 2.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-vesa/Manifest1
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/Manifest b/x11-drivers/xf86-video-vesa/Manifest
index 603fb88dd79d..97aa7078fd6d 100644
--- a/x11-drivers/xf86-video-vesa/Manifest
+++ b/x11-drivers/xf86-video-vesa/Manifest
@@ -1 +1,2 @@
DIST xf86-video-vesa-2.4.0.tar.bz2 324599 BLAKE2B ddaa7a54d439b1afb1152e15e0d436cade79c51a61e78837a066e3e0c04d4a2ea6b079e68eca917e618aae125ed4eab7734009a337018460e771265b8daef443 SHA512 4af5c0a7fd64eba503980198cf510688dff2f33482ceac446455d97255dcc828613387ac57828eb6dce080cb15a8644a2b2e278bf356705fdeaea873ab07c2de
+DIST xf86-video-vesa-2.5.0.tar.bz2 304322 BLAKE2B aee8b59d769a72fb2890bbadde7fb87e2f527fb58eaf8b2ef515b0a1b7dc591c6afaf1d8692caaaefb741f475ed77bc0ed069be43a752103260bc85314a7a830 SHA512 36fd921f54f33eb25966b5f9ea1e1b3e9009965c012c8b9c676686b472111719921b80cf62dafc746058878253e21f0ef341a2ff2d650df22ca1e35e81716a8b
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild
new file mode 100644
index 000000000000..95d712819800
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit linux-info xorg-3
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ >=x11-libs/libpciaccess-0.12.901"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}