summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-25 00:42:07 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-25 01:04:17 +0100
commit11364af32b42862a7b2a8b8903bcd74b8d3721a8 (patch)
treec6fca54fb2bbd0b5e087c14debc3a8f92c41d33a /x11-libs/dnd
parentdev-libs/hiredis: remove old (diff)
downloadgentoo-11364af32b42862a7b2a8b8903bcd74b8d3721a8.tar.gz
gentoo-11364af32b42862a7b2a8b8903bcd74b8d3721a8.tar.bz2
gentoo-11364af32b42862a7b2a8b8903bcd74b8d3721a8.zip
x11-libs/dnd: EAPI 6 bump.
Package-Manager: portage-2.3.3
Diffstat (limited to 'x11-libs/dnd')
-rw-r--r--x11-libs/dnd/dnd-1.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/dnd/dnd-1.1-r2.ebuild b/x11-libs/dnd/dnd-1.1-r2.ebuild
new file mode 100644
index 000000000000..d90dac9b7066
--- /dev/null
+++ b/x11-libs/dnd/dnd-1.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="OffiX' Drag'n'drop library"
+HOMEPAGE="http://leb.net/offix"
+SRC_URI="http://leb.net/offix/${PN}.${PV}.tgz"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libICE
+ x11-libs/libXaw
+ x11-proto/xproto"
+
+DEPEND="
+ ${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/Makefile-fix.patch
+)
+
+S="${WORKDIR}/DND/DNDlib"
+
+src_configure() {
+ tc-export CC CXX RANLIB AR
+ econf --with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+}