summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-18 00:47:33 -0400
committerSam James <sam@gentoo.org>2024-03-18 05:30:06 +0000
commite67e2dfb1c97c5a13d23faf243e5c9c0e2a23c4d (patch)
treebffac61dd805e6a361a6eb721765f3c47530ea4b /x11-libs/fltk
parentx11-libs/fltk: add github upstream metadata (diff)
downloadgentoo-e67e2dfb1c97c5a13d23faf243e5c9c0e2a23c4d.tar.gz
gentoo-e67e2dfb1c97c5a13d23faf243e5c9c0e2a23c4d.tar.bz2
gentoo-e67e2dfb1c97c5a13d23faf243e5c9c0e2a23c4d.zip
x11-libs/fltk: try to re-sync the live ebuild for 1.4
Some DOCS files disappeared, some patches needed to be rerolled. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-cmake.patch19
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch42
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch14
-rw-r--r--x11-libs/fltk/files/fltk-1.4.9999-optim.patch13
-rw-r--r--x11-libs/fltk/fltk-1.4.9999.ebuild14
5 files changed, 92 insertions, 10 deletions
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-cmake.patch b/x11-libs/fltk/files/fltk-1.4.9999-cmake.patch
new file mode 100644
index 000000000000..3f576d501ece
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-cmake.patch
@@ -0,0 +1,19 @@
+diff --git a/configure.ac b/configure.ac
+index 6b64110b0..1330d3f27 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1878,10 +1878,13 @@ dnl Set empty BINARY_DIR variable for fltk-config.in (CMake compatibility)
+ BINARY_DIR=
+ AC_SUBST([BINARY_DIR])
+
++INCLUDE_DIRS="${includedir}"
++AC_SUBST(INCLUDE_DIRS)
++
+ dnl Write all of the files...
+ AC_CONFIG_HEADERS([config.h:configh.in])
+ AC_CONFIG_HEADERS([FL/fl_config.h:fl_config.in])
+-AC_CONFIG_FILES([makeinclude fltk.list fltk-config fltk.spec FL/Makefile])
++AC_CONFIG_FILES([makeinclude fltk.list fltk-config fltk.spec FL/Makefile CMake/FLTKConfig.cmake])
+ AC_OUTPUT
+
+ dnl Make sure the fltk-config script is executable...
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch b/x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch
new file mode 100644
index 000000000000..47db8d03c8d2
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-conf-tests.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index 2d99808d9..283f825dd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -103,9 +103,6 @@ makeinclude: configure configh.in makeinclude.in
+ touch config.h
+ chmod +x fltk-config
+
+-configure: configure.ac
+- autoconf
+-
+ portable-dist:
+ epm -v -s fltk.xpm fltk
+
+diff --git a/documentation/Makefile b/documentation/Makefile
+index 0b176246b..882fbf8a4 100644
+--- a/documentation/Makefile
++++ b/documentation/Makefile
+@@ -91,12 +91,6 @@ install: $(MANPAGES)
+ $(INSTALL_DATA) fltk.pdf $(DESTDIR)$(docdir); \
+ fi
+ echo "Installing man pages in $(DESTDIR)$(mandir) ..."
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-options.$(CAT1EXT) $(DESTDIR)$(mandir)/cat1
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat3
+- $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.$(CAT3EXT) $(DESTDIR)$(mandir)/cat3
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fluid.man $(DESTDIR)$(mandir)/man1/fluid.1
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk-config.man $(DESTDIR)$(mandir)/man1/fltk-config.1
+@@ -105,10 +99,6 @@ install: $(MANPAGES)
+ $(INSTALL_MAN) $(SRC_DOCDIR)/fltk.man $(DESTDIR)$(mandir)/man3/fltk.3
+
+ install-linux install-osx:
+- -$(INSTALL_DIR) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+- $(INSTALL_MAN) $(SRC_DOCDIR)/sudoku.$(CAT6EXT) $(DESTDIR)$(mandir)/cat6
+ -$(INSTALL_DIR) $(DESTDIR)$(mandir)/man6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/blocks.man $(DESTDIR)$(mandir)/man6/blocks.6
+ $(INSTALL_MAN) $(SRC_DOCDIR)/checkers.man $(DESTDIR)$(mandir)/man6/checkers.6
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch b/x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch
new file mode 100644
index 000000000000..e49aa7408cca
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-makefile-dirs.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index c02de0972..2d99808d9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,8 +16,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) $(LIBDECORDIR) src $(CAIRODIR) $(FLUIDDIR) fltk-options test \
+- documentation
++DIRS = $(IMAGEDIRS) $(LIBDECORDIR) src $(CAIRODIR) fltk-options
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/x11-libs/fltk/files/fltk-1.4.9999-optim.patch b/x11-libs/fltk/files/fltk-1.4.9999-optim.patch
new file mode 100644
index 000000000000..a1e18bbb74b2
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.4.9999-optim.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 1330d3f27..c76dba26f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1552,7 +1552,7 @@ AS_IF([test -n "$GCC"], [
+ AS_IF([test "x$with_optim" != x], [
+ OPTIM="$with_optim $OPTIM"
+ ], [
+- OPTIM="-Os $OPTIM"
++ OPTIM="$OPTIM"
+ ])
+ ])
+
diff --git a/x11-libs/fltk/fltk-1.4.9999.ebuild b/x11-libs/fltk/fltk-1.4.9999.ebuild
index 3504795dbf4a..74b44b10b0b6 100644
--- a/x11-libs/fltk/fltk-1.4.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.4.9999.ebuild
@@ -46,15 +46,12 @@ DOCS=(
CHANGES_1.1.txt
CHANGES_1.3.txt
CREDITS.txt
- README.Android.md
README.CMake.txt
README.Cairo.txt
README.IDE.txt
- README.Pico.txt
README.Unix.txt
README.Windows.txt
README.abi-version.txt
- README.bundled-libs.txt
README.macOS.md
README.md
README.txt
@@ -66,10 +63,10 @@ FLTK_GAMES="
"
PATCHES=(
"${FILESDIR}"/${PN}-1.3.0-share.patch
- "${FILESDIR}"/${PN}-1.3.3-makefile-dirs.patch
- "${FILESDIR}"/${PN}-1.3.4-conf-tests.patch
- "${FILESDIR}"/${PN}-1.3.5-cmake.patch
- "${FILESDIR}"/${PN}-1.3.5-optim.patch
+ "${FILESDIR}"/${PN}-1.4.9999-makefile-dirs.patch
+ "${FILESDIR}"/${PN}-1.4.9999-conf-tests.patch
+ "${FILESDIR}"/${PN}-1.4.9999-cmake.patch
+ "${FILESDIR}"/${PN}-1.4.9999-optim.patch
)
pkg_setup() {
@@ -95,9 +92,6 @@ src_prepare() {
-e "/SILENT:/d" \
makeinclude.in || die
- # also in Makefile:config.guess config.sub:
- cp misc/config.{guess,sub} . || die
-
eautoconf
multilib_copy_sources
}