summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-25 15:59:51 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-25 15:59:51 +0100
commit342dd44472d0c0f9f99a3af077e0fe44771cca36 (patch)
treed77122fa6779efc48a89940f63461a17b88230b0 /x11-libs/libast
parentx11-libs/xforms: take over maintainership. (diff)
downloadgentoo-342dd44472d0c0f9f99a3af077e0fe44771cca36.tar.gz
gentoo-342dd44472d0c0f9f99a3af077e0fe44771cca36.tar.bz2
gentoo-342dd44472d0c0f9f99a3af077e0fe44771cca36.zip
x11-libs/libast: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/libast-0.7-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/libast/libast-0.7-r1.ebuild b/x11-libs/libast/libast-0.7-r1.ebuild
new file mode 100644
index 000000000000..ca8be40d6d34
--- /dev/null
+++ b/x11-libs/libast/libast-0.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="
+ !sci-astronomy/ast
+ x11-libs/libXt
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ media-libs/freetype
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README DESIGN ChangeLog )
+
+src_prepare() {
+ default
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp="${myregexp}"
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install
+}