summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 12:03:32 +0100
committerSam James <sam@gentoo.org>2022-10-04 12:16:40 +0100
commitf5b83487a535eab3d9a731b929b226db9be79dfb (patch)
tree191cd7765d21d091f711e71af2776b62b3c66475 /x11-libs/libast
parentx11-libs/libast: add github upstream metadata (diff)
downloadgentoo-f5b83487a535eab3d9a731b929b226db9be79dfb.tar.gz
gentoo-f5b83487a535eab3d9a731b929b226db9be79dfb.tar.bz2
gentoo-f5b83487a535eab3d9a731b929b226db9be79dfb.zip
x11-libs/libast: add 0.8
Closes: https://bugs.gentoo.org/871705 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/Manifest1
-rw-r--r--x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch15
-rw-r--r--x11-libs/libast/libast-0.8.ebuild48
3 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
index 625316657e63..588b0f8da273 100644
--- a/x11-libs/libast/Manifest
+++ b/x11-libs/libast/Manifest
@@ -1 +1,2 @@
DIST libast-0.7.tar.gz 508654 BLAKE2B 0c5bf31d5b73fe11d4665bc0d8e1c9a987b944fcdcd89106a47ebf01eb90c2895b3e74e39874b360e91f027b8beaf5698363e9920ad879bfd241b13ef0232870 SHA512 0af1d508af88ce0a2f29fe7841e23759be7c6540a1e2698980c289245ba284fdbf76c593e457c0cd6cfc54dcb6d891b01a3fd4d4a6ecc511fb2de698c9a3046d
+DIST libast-0.8.tar.gz 254188 BLAKE2B 02fc2872218f11cb4083d451377fdc46369c2ef7d1f0e547831dfdf4ecec2cd6aaf3453e9e8ef8431fbd5e3cd75e828e3c5967a6311853e7e87f583ef2be72c8 SHA512 266a479fdbfc479e233675fa7623488135c633fed9cb236ec0cee578fc5be83b88a2dbda8a304ee3a27384c96e93a4bdf40f60597660e09841380e0930dd93d9
diff --git a/x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch b/x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch
new file mode 100644
index 000000000000..34e55f7d43aa
--- /dev/null
+++ b/x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/871705
+--- a/src/snprintf.c
++++ b/src/snprintf.c
+@@ -2,6 +2,11 @@
+ # include <config.h>
+ #endif
+
++#include <ctype.h>
++#include <stddef.h>
++#include <string.h>
++#include <stdio.h>
++
+ #include <errno.h>
+ #if defined(HAVE_STDARG_H) && (HAVE_STDARG_H != 0)
+ # include <stdarg.h>
diff --git a/x11-libs/libast/libast-0.8.ebuild b/x11-libs/libast/libast-0.8.ebuild
new file mode 100644
index 000000000000..396c0cb77b4d
--- /dev/null
+++ b/x11-libs/libast/libast-0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="https://github.com/mej/libast/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="
+ !sci-astronomy/ast
+ x11-base/xorg-proto
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ media-libs/freetype
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp=$(usex pcre pcre posix)
+}
+
+src_install() {
+ default
+
+ dodoc DESIGN
+
+ find "${ED}" -name '*.la' -delete || die
+}