summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-15 06:40:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-15 06:40:09 +0100
commit411c653689ca2ef5f5028dae10f377ad26bb31ac (patch)
tree21f715be8fdcd0bff1aa9bf92600efcc31c30fb3 /x11-libs/libva
parentx11-libs/libva: Remove old (diff)
downloadgentoo-411c653689ca2ef5f5028dae10f377ad26bb31ac.tar.gz
gentoo-411c653689ca2ef5f5028dae10f377ad26bb31ac.tar.bz2
gentoo-411c653689ca2ef5f5028dae10f377ad26bb31ac.zip
x11-libs/libva: bump to 2.1.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-libs/libva')
-rw-r--r--x11-libs/libva/Manifest1
-rw-r--r--x11-libs/libva/libva-2.1.0.ebuild79
-rw-r--r--x11-libs/libva/libva-9999.ebuild6
3 files changed, 83 insertions, 3 deletions
diff --git a/x11-libs/libva/Manifest b/x11-libs/libva/Manifest
index 7f07ae3864fd..0ba7aea90522 100644
--- a/x11-libs/libva/Manifest
+++ b/x11-libs/libva/Manifest
@@ -1,3 +1,4 @@
DIST libva-1.7.3.tar.bz2 824490 BLAKE2B 0579492b700b00e9ed009798e6dcf6dd7fd6cd19e32af9fbab6d780ba83ae3a264dbbfab2633a3458a624fec1935435974875e58a9e57baca9be9cb7ce627488 SHA512 ecc1ba17e2afea2efe4d36e8d9358d420015b3ad9d2a510ee2b263274c889caf39915a8b8da2d16329184bf4f42d0cbd124af3d070b83235b6a7453afd30b3a0
DIST libva-1.8.3.tar.gz 186915 BLAKE2B 10713e3bd7aaefc033490fc9ef6485ec50774f274f09e9e06fd1479b882b221791375533a6826e5db9a758f2acd74f913a478da61fe32250a3e2d9c0062739fc SHA512 f2f360876d8443a22a3434aa1ac7ec5aa6d4b3cc1f13f475ef74e716f5937acc43e02f9a8b858b5b7b6539da3731f763843d45664cc19c70e81d8b87e93659ea
DIST libva-2.0.0.tar.gz 191311 BLAKE2B 1515c39f9ff12137b07f753101692c71a5bdd3e9a1e00da427d373307277aff950a31038d132902b4554cb290209b1b29038214de3e9d34c545e6d9854267fb7 SHA512 85c47355d95026e88ad443dbfb2e2dc12c37961dbc001fc051f85e8adada46da9a350cf5d2fe20943ca36fe749f49f88f85f8ee1b9fb93d69b32a75f710609d6
+DIST libva-2.1.0.tar.gz 214894 BLAKE2B 0e29d3de915ce44d90ac96bc2ead73725efc34163da92da7d8791547d6ca2fd407319093fee89bce5b26b26818cc0131cc0c7f3cd4f511e3f847e3fd2cf1dff3 SHA512 dd4c901f9c75d03fa45b32af5ca08ba24ef68d354ad26ad53d0f87d3290bee152eed9e61b4dd4116c2d15baf0c74f2d37996d08f007d485c57af5e8d9648eb82
diff --git a/x11-libs/libva/libva-2.1.0.ebuild b/x11-libs/libva/libva-2.1.0.ebuild
new file mode 100644
index 000000000000..2cfeb67ae2f1
--- /dev/null
+++ b/x11-libs/libva/libva-2.1.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM} multilib versionator
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0/$(get_version_component_range 1)"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm opengl vdpau wayland X utils"
+
+VIDEO_CARDS="nvidia intel i965 nouveau"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_nouveau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r3[${MULTILIB_USEDEP}] )
+ vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-2.0.0[${MULTILIB_USEDEP}] )
+ video_cards_i965? ( >=x11-libs/libva-intel-driver-2.0.0[${MULTILIB_USEDEP}] )
+ utils? ( media-video/libva-utils )
+ "
+
+REQUIRED_USE="|| ( drm wayland X )
+ opengl? ( X )"
+
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+/usr/include/va/va_backend_glx.h
+/usr/include/va/va_x11.h
+/usr/include/va/va_dri2.h
+/usr/include/va/va_dricommon.h
+/usr/include/va/va_glx.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ )
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 56a848add454..2cfeb67ae2f1 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,7 +7,7 @@ SCM=""
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SCM=git-r3
EGIT_BRANCH=master
- EGIT_REPO_URI="https://github.com/01org/libva"
+ EGIT_REPO_URI="https://github.com/intel/libva"
fi
AUTOTOOLS_AUTORECONF="yes"
@@ -18,7 +18,7 @@ HOMEPAGE="https://01.org/linuxmedia/vaapi"
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SRC_URI=""
else
- SRC_URI="https://github.com/01org/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="MIT"