summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-01-08 17:44:43 +0300
committerSam James <sam@gentoo.org>2021-01-08 15:13:20 +0000
commitdb6d6a2bfb96faac0f8372f7bde13e9b73050a1e (patch)
treedf53ef0355e3c298372fe0f5e55b0bebb5ab62b1 /x11-libs/libva
parentgames-puzzle/nudoku: add gettext/libintl deps (diff)
downloadgentoo-db6d6a2bfb96faac0f8372f7bde13e9b73050a1e.tar.gz
gentoo-db6d6a2bfb96faac0f8372f7bde13e9b73050a1e.tar.bz2
gentoo-db6d6a2bfb96faac0f8372f7bde13e9b73050a1e.zip
x11-libs/libva: added version 2.9.1
Fixed DOCS installation (missing "default" in src_install()) Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs/libva')
-rw-r--r--x11-libs/libva/Manifest1
-rw-r--r--x11-libs/libva/libva-2.9.1.ebuild91
-rw-r--r--x11-libs/libva/libva-9999.ebuild34
3 files changed, 113 insertions, 13 deletions
diff --git a/x11-libs/libva/Manifest b/x11-libs/libva/Manifest
index fed90aafaeeb..6b637b6a7e61 100644
--- a/x11-libs/libva/Manifest
+++ b/x11-libs/libva/Manifest
@@ -3,3 +3,4 @@ DIST libva-2.6.1.tar.bz2 466497 BLAKE2B d4ea6e6d0102722206d94725932f0b3cf650bab3
DIST libva-2.7.1.tar.bz2 477933 BLAKE2B 261e608af3f1427bed0244d4ebbc0d3ffe5681669ecb3583a8910568bc96817b8da079ffe80915ecf1002f9ac247eea5e44f8f7ce305313719fc1a4f1c5892b3 SHA512 f4b88ca0216f0ea4d934edcd322b8f741833b5a50ee2f34a3ecf60d635082b29e2dd032734c2f9d2a680e3b9c98e61a8b9432ea639a9fd5389761e04782c1126
DIST libva-2.8.0.tar.bz2 478734 BLAKE2B b11393a9b9ec7ef4cf91d20d4005d42ad3d0e6a4a8e4d8cda67816bc5b9d3b23900754b5e8af92386dcf99a11e53af70fc4723ffecc715328c8fbf3d40486098 SHA512 329c5fc2262a6f4fddfcb13bd9644589248be6ae18fa1481cccc6b33874b91b60ad3f16a1777712f7a4817ba576db984834aa8735e6ad13d99b2f5aa13e9ddfa
DIST libva-2.9.0.tar.bz2 481556 BLAKE2B 5509f3d7df11a11602331a3b6bb78d3a5d3dfbeff024eaa77594918c49cd48ec9e8ee017d8ac7b4aa1dbd3252a23caecce9a10a8a9e12ef4c483a8a34e028b20 SHA512 496358b73cd525d8c9dc1fcf3dbf992ec997ecc8f7be31f0e226ded173aecf29d8d4b60cc7cc5ee7beac538061659841145f67f449a03a04236a6ee7ae6f8323
+DIST libva-2.9.1.tar.gz 240934 BLAKE2B 76333a9ce78783c3d94798a19ea6a52d95768ca7e5a547094290313d4f5c610841787d4420d19e0553174933beaf5fbf68e7e849ad38682173f670de0d9a76e5 SHA512 79fd0b41795ac5de68bdd6470389fad6caf016fa4a44f2cd775c0a65d6d8f270a7e237d3b2e42a90376c103d2d2e2c010fe47835c7a15d79b94beaced02a2884
diff --git a/x11-libs/libva/libva-2.9.1.ebuild b/x11-libs/libva/libva-2.9.1.ebuild
new file mode 100644
index 000000000000..89ac22133fa6
--- /dev/null
+++ b/x11-libs/libva/libva-2.9.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+
+inherit autotools
+
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva"
+else
+ # SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
+ # The upstream provides periodically tarball with pre-built 'configure'.
+ # To simplify updates, portage use tarballs without pre-build 'configure'
+ # which are always available.
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1)"
+IUSE="+drm opengl utils vdpau wayland X"
+
+VIDEO_CARDS="nvidia intel i965 nouveau"
+for x in ${VIDEO_CARDS}; do
+ IUSE+=" video_cards_${x}"
+done
+
+RDEPEND="
+ >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_nouveau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r3[${MULTILIB_USEDEP}] )
+ vdpau? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB_USEDEP}] )
+ video_cards_intel? ( >=x11-libs/libva-intel-driver-2.0.0[${MULTILIB_USEDEP}] )
+ video_cards_i965? ( >=x11-libs/libva-intel-driver-2.0.0[${MULTILIB_USEDEP}] )
+ utils? ( media-video/libva-utils )
+"
+
+REQUIRED_USE="|| ( drm wayland X )
+ opengl? ( X )"
+
+# CONTRIBUTING.md and README.md are avaialbe only in .tar.gz tarballs
+DOCS=( NEWS CONTRIBUTING.md README.md )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/va/va_backend_glx.h
+ /usr/include/va/va_x11.h
+ /usr/include/va/va_dri2.h
+ /usr/include/va/va_dricommon.h
+ /usr/include/va/va_glx.h
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ --enable-va-messaging
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 016d79e6442e..812111b4ebad 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,14 +8,19 @@ inherit multilib-minimal
DESCRIPTION="Video Acceleration (VA) API for Linux"
HOMEPAGE="https://01.org/linuxmedia/vaapi"
-if [[ ${PV} = *9999* ]] ; then # Live ebuild
- inherit autotools git-r3
+inherit autotools
+
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
EGIT_BRANCH=master
EGIT_REPO_URI="https://github.com/intel/libva"
- AUTOTOOLS_AUTORECONF="yes"
else
- SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ # SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
+ # The upstream provides periodically tarball with pre-built 'configure'.
+ # To simplify updates, portage use tarballs without pre-build 'configure'
+ # which are always available.
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="MIT"
@@ -52,19 +57,20 @@ PDEPEND="video_cards_nvidia? ( >=x11-libs/libva-vdpau-driver-0.7.4-r1[${MULTILIB
REQUIRED_USE="|| ( drm wayland X )
opengl? ( X )"
-DOCS=( NEWS )
+# CONTRIBUTING.md and README.md are avaialbe only in .tar.gz tarballs and in git
+DOCS=( NEWS CONTRIBUTING.md README.md )
MULTILIB_WRAPPED_HEADERS=(
-/usr/include/va/va_backend_glx.h
-/usr/include/va/va_x11.h
-/usr/include/va/va_dri2.h
-/usr/include/va/va_dricommon.h
-/usr/include/va/va_glx.h
+ /usr/include/va/va_backend_glx.h
+ /usr/include/va/va_x11.h
+ /usr/include/va/va_dri2.h
+ /usr/include/va/va_dricommon.h
+ /usr/include/va/va_glx.h
)
src_prepare() {
default
- [[ "${PV}" == *9999* ]] && eautoreconf
+ eautoreconf
}
multilib_src_configure() {
@@ -74,10 +80,12 @@ multilib_src_configure() {
$(use_enable X x11)
$(use_enable wayland)
$(use_enable drm)
+ --enable-va-messaging
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
+ default
find "${ED}" -type f -name "*.la" -delete || die
}