summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 22:34:16 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 23:40:03 +0100
commit19d21eb89c5bf70b765c319f76f24c223a313742 (patch)
treeed603ff82d2bb924dec02729c4cbe32fd5e624b4 /x11-libs/qwtplot3d
parentsci-libs/liborigin: fix header location in pc file (diff)
downloadgentoo-19d21eb89c5bf70b765c319f76f24c223a313742.tar.gz
gentoo-19d21eb89c5bf70b765c319f76f24c223a313742.tar.bz2
gentoo-19d21eb89c5bf70b765c319f76f24c223a313742.zip
x11-libs/qwtplot3d: install version.h
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'x11-libs/qwtplot3d')
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch b/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
index 611f9111b38b..c32dccaa09d7 100644
--- a/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
@@ -1,5 +1,5 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 12657be..5306d02 100644
+index 12657be..c14ca89 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,5 @@
@@ -8,8 +8,13 @@ index 12657be..5306d02 100644
project( QwtPlot3D
VERSION 0.3.0
-@@ -106,6 +107,7 @@ set( HEADERS
+@@ -104,8 +105,12 @@ set( HEADERS
+ "include/qwt3d_io_gl2ps.h"
+ )
configure_file( "include/qwt3d_version.h.in" "qwt3d_version.h" @ONLY )
++list( APPEND HEADERS
++ "${CMAKE_BINARY_DIR}/qwt3d_version.h"
++ )
add_library( qwtplot3d ${SRCS} ${HEADERS} )
+set_target_properties( qwtplot3d PROPERTIES PUBLIC_HEADER "${HEADERS}" )