summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 08:34:00 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 08:42:43 -0400
commit0ce4e96a0ffee289aacf43385a070a67f0e8a024 (patch)
tree6649496fabd1aeb5999d06bc35132722d135efdf /x11-libs/vte
parentmedia-libs/mesa: Drop old versions (diff)
downloadgentoo-0ce4e96a0ffee289aacf43385a070a67f0e8a024.tar.gz
gentoo-0ce4e96a0ffee289aacf43385a070a67f0e8a024.tar.bz2
gentoo-0ce4e96a0ffee289aacf43385a070a67f0e8a024.zip
x11-libs/vte: use ${EPYTHON}, not python3
Closes: https://bugs.gentoo.org/787290 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch48
-rw-r--r--x11-libs/vte/vte-0.64.1.ebuild8
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch b/x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch
new file mode 100644
index 000000000000..79171d29dead
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch
@@ -0,0 +1,48 @@
+https://gitlab.gnome.org/GNOME/vte/-/issues/350
+
+From d459d32126119c8d78f8239b8b857a255e6005d7 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sat, 1 May 2021 08:31:45 -0400
+Subject: [PATCH] meson: Find python explicitly to honor downstream python
+ choice
+
+---
+ meson.build | 1 +
+ src/meson.build | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 4f5a7c57..6404802f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -461,6 +461,7 @@ pango_dep = dependency('pango', version: '>=' + pango_req_version)
+ pcre2_dep = dependency('libpcre2-8', version: '>=' + pcre2_req_version)
+ pthreads_dep = dependency('threads')
+ zlib_dep = dependency('zlib')
++python = import('python').find_installation('python3')
+
+ if get_option('fribidi')
+ fribidi_dep = dependency('fribidi', version: '>=' + fribidi_req_version)
+diff --git a/src/meson.build b/src/meson.build
+index a1440da5..4ac6a7f2 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -60,6 +60,7 @@ modes_sources = files(
+ modes_sources += custom_target(
+ 'modes',
+ command: [
++ python,
+ files('modes.py'),
+ '--destdir', '@OUTDIR@',
+ ],
+@@ -92,6 +93,7 @@ parser_sources = files(
+ parser_sources += custom_target(
+ 'parser-seq',
+ command: [
++ python,
+ files('parser-seq.py'),
+ '--destdir', '@OUTDIR@',
+ ],
+--
+2.26.3
+
diff --git a/x11-libs/vte/vte-0.64.1.ebuild b/x11-libs/vte/vte-0.64.1.ebuild
index e1499ad22159..5d3ccf349ace 100644
--- a/x11-libs/vte/vte-0.64.1.ebuild
+++ b/x11-libs/vte/vte-0.64.1.ebuild
@@ -2,10 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
VALA_USE_DEPEND="vapigen"
VALA_MIN_API_VERSION="0.32"
-inherit gnome.org meson vala xdg
+inherit gnome.org meson python-any-r1 vala xdg
DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
@@ -35,6 +36,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
+ ${PYTHON_DEPS}
dev-libs/libxml2:2
dev-util/glib-utils
gtk-doc? ( >=dev-util/gtk-doc-1.13
@@ -45,6 +47,10 @@ BDEPEND="
vala? ( $(vala_depend) )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.64.1-meson-Find-python-explicitly-to-honor-downstream-pyt.patch
+)
+
src_prepare() {
if ! use vanilla; then
# Part of https://src.fedoraproject.org/rpms/vte291/raw/f31/f/vte291-cntnr-precmd-preexec-scroll.patch