summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/dex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/dex')
-rw-r--r--x11-misc/dex/Manifest2
-rw-r--r--x11-misc/dex/dex-0.6.ebuild32
-rw-r--r--x11-misc/dex/dex-0.7.ebuild30
-rw-r--r--x11-misc/dex/metadata.xml11
4 files changed, 75 insertions, 0 deletions
diff --git a/x11-misc/dex/Manifest b/x11-misc/dex/Manifest
new file mode 100644
index 000000000000..f78ab2ccadc8
--- /dev/null
+++ b/x11-misc/dex/Manifest
@@ -0,0 +1,2 @@
+DIST dex-0.6.tar.gz 7389 SHA256 8e31bdde6b2450244c9b0a8e337997cb08b3e65626d2bf7a4dadddb19ceef0f1 SHA512 d479c51a758f9bae513c7a8f0ca0e19004f954f6ea7284b077c3602a660bd2d0ddcb3866d84b04b6bf46e64a5c7d55e1d220044034d9bb88d12ed1599d99fd6a WHIRLPOOL 409e9092781a6e31e3d41710099622fd8c41cba138b3235f796983a2e3fa45391fd7b0b1ae3cd638ddeb35990b36e88e3d729daa113dd78a68b789ba7712c947
+DIST dex-0.7.tar.gz 7679 SHA256 2b0c98832c4b894486807a9ac0417ca127425013e0f07da352621065cb36adc6 SHA512 ee1f8c6ef0b374aadf6ad0ee6482bb23f740f67888994839c381b71b3655d0cbd7d3d5c99abe5f3bce856cb767a1b4bffdbcdf6c70969226b44a59ee76943bce WHIRLPOOL 18606fe1f7f82010101c4998126505530bf7eb0e4fccfc5f9ce7d4c3d48375424d824af484d8927f2f245ee455994c91fc0772a7b47dc2e165cc38eed1917031
diff --git a/x11-misc/dex/dex-0.6.ebuild b/x11-misc/dex/dex-0.6.ebuild
new file mode 100644
index 000000000000..328b233a0f38
--- /dev/null
+++ b/x11-misc/dex/dex-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit eutils python-r1
+
+DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
+HOMEPAGE="http://e-jc.de/"
+SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin dex
+ python_replicate_script "${ED}/usr/bin/dex"
+ dodoc README
+ doman dex.1
+}
diff --git a/x11-misc/dex/dex-0.7.ebuild b/x11-misc/dex/dex-0.7.ebuild
new file mode 100644
index 000000000000..46b1c6d1c26a
--- /dev/null
+++ b/x11-misc/dex/dex-0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit eutils python-r1
+
+DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
+HOMEPAGE="http://e-jc.de/"
+SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin dex
+ python_replicate_script "${ED}/usr/bin/dex"
+ dodoc README
+ doman dex.1
+}
diff --git a/x11-misc/dex/metadata.xml b/x11-misc/dex/metadata.xml
new file mode 100644
index 000000000000..7b0ac3cd3a83
--- /dev/null
+++ b/x11-misc/dex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jceb/dex</remote-id>
+ </upstream>
+</pkgmetadata>