summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-20 11:15:58 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-20 11:19:12 +0200
commit0071e9ccbf1820758d4b066ae691553d1398a39a (patch)
tree17220e0884b56b1f6cb27b1966562c81ee5044b7 /x11-misc
parentwww-client/firefox: amd64 stable wrt bug #688332 (diff)
downloadgentoo-0071e9ccbf1820758d4b066ae691553d1398a39a.tar.gz
gentoo-0071e9ccbf1820758d4b066ae691553d1398a39a.tar.bz2
gentoo-0071e9ccbf1820758d4b066ae691553d1398a39a.zip
x11-misc/xlockmore: Version 5.57
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xlockmore/Manifest1
-rw-r--r--x11-misc/xlockmore/xlockmore-5.57.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/Manifest b/x11-misc/xlockmore/Manifest
index ba1333a7ea22..b8e55142cc84 100644
--- a/x11-misc/xlockmore/Manifest
+++ b/x11-misc/xlockmore/Manifest
@@ -2,3 +2,4 @@ DIST ax_pthread.m4.xz 6356 BLAKE2B 784bfa3fcae2499230acba588cea5591f62229d721cac
DIST xlockmore-5.50.tar.xz 1632968 BLAKE2B 2e692d16d70e3186ec1f31c192414b286f8815f2f428a6f7f43b3de0117c51c4ad2fbdfb91debe2ecb75c8683212b5d33bee62d81374552703d578b02d3af036 SHA512 627a905c4641d6083676a766931f23c06e2ac5af9b43447ccf03143d329d24b786aac6b248318929399b5fae98f1ec17e676466b5cbd09f180377c483694c569
DIST xlockmore-5.55.tar.xz 1650116 BLAKE2B 4c50f9a0f4f4c5d02c002363e75eef22b19f52cb05db305f013bb105d47f3981b00f65ee66937c9bb7d971772cda90e2565345fff25fb8c593cdeefa0cf10ca7 SHA512 b6d322bbfbf5710c0fb94da6ee894902fe6c2c87f949c80a27f7924c26a20ede5a3bc40a085c00d4a41dae450c862edaa4d50f716bf3041668d89c7c1d8b4902
DIST xlockmore-5.56.tar.xz 1649808 BLAKE2B 82d56a3570bd1be52014503d7c0a36cf27f68aaf31fe4a7ed06159dc796dbd1410711a56fa8e72709499b1ceb3063b2acd9646ba38400669d3671d04e9fb5745 SHA512 1ae5cde5d0167897229e9cb8ebd15e26fdeadc9b0e2d221e6334980f23403385bf1adbd44a955b455e3ecdf8b02b18b0e06273d8dc566b17ac3692ee5ae44f4d
+DIST xlockmore-5.57.tar.xz 1835880 BLAKE2B b26a9792286ded7647c816b907107b9c524ddbf46afab94c5b6b5dc5d5c918f5715c914ce4246497018bd56fd11329bcd1afe07608e44a70d24dd2c4c3d97e38 SHA512 2107efc7e1e9c811b6f86e9bb048dae3861a4e2f421b3d963856a77746834c08c5d349dc15cb3bc9b9aaf21abdc8f0e4af9463a90359b575604f3393c325400f
diff --git a/x11-misc/xlockmore/xlockmore-5.57.ebuild b/x11-misc/xlockmore/xlockmore-5.57.ebuild
new file mode 100644
index 000000000000..360f6c9070f1
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.57.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="http://www.sillycycle.com/xlockmore.html"
+SRC_URI="
+ http://www.sillycycle.com/xlock/${P/_alpha/ALPHA}.tar.xz
+ https://dev.gentoo.org/~jer/ax_pthread.m4.xz
+"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug gtk imagemagick motif nas opengl pam truetype xinerama xlockrc vtlock"
+
+REQUIRED_USE="
+ || ( crypt pam )
+ pam? ( !xlockrc )
+ xlockrc? ( !pam )
+"
+RDEPEND="
+ gtk? ( x11-libs/gtk+:2 )
+ imagemagick? ( media-gfx/imagemagick:= )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ nas? ( media-libs/nas )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 )
+ )
+ pam? ( virtual/pam )
+ truetype? ( media-libs/freetype:2 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.46-freetype261.patch
+ "${FILESDIR}"/${PN}-5.47-CXX.patch
+ "${FILESDIR}"/${PN}-5.47-strip.patch
+)
+S=${WORKDIR}/${P/_alpha/ALPHA}
+
+src_unpack() {
+ unpack ${P/_alpha/ALPHA}.tar.xz
+ xz -cd ${DISTDIR}/ax_pthread.m4.xz > ${S}/ax_pthread.m4 || die
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use opengl && use truetype; then
+ myconf=( --with-ftgl )
+ append-flags -DFTGL213
+ else
+ myconf=( --without-ftgl )
+ fi
+
+ myconf+=(
+ $(use_enable pam)
+ $(use_enable xlockrc)
+ $(use_enable vtlock)
+ $(use_with crypt)
+ $(use_with debug editres)
+ $(use_with gtk gtk2)
+ $(use_with imagemagick magick)
+ $(use_with motif)
+ $(use_with nas)
+ $(use_with opengl mesa)
+ $(use_with opengl)
+ $(use_with truetype freetype)
+ $(use_with truetype ttf)
+ $(use_with xinerama)
+ --disable-mb
+ --enable-appdefaultdir=/usr/share/X11/app-defaults
+ --enable-syslog
+ --enable-vtlock
+ --without-esound
+ --without-gtk
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ local DOCS=( README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO} )
+ default
+
+ pamd_mimic_system xlock auth
+
+ if use pam; then
+ fperms 755 /usr/bin/xlock
+ else
+ fperms 4755 /usr/bin/xlock
+ fi
+
+ docinto html
+ dodoc docs/xlock.html
+}