summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Miller <alex.miller@gmx.de>2021-02-21 17:31:57 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-21 17:31:57 +0100
commit9188d6279746a346888b23503d2ae78f29c978c8 (patch)
tree6b18a6d38e9be960f40b98b39645103d3287f8b4 /x11-misc
parentx11-misc/rss-glx: Fix C++11 narrowing issues (diff)
downloadgentoo-9188d6279746a346888b23503d2ae78f29c978c8.tar.gz
gentoo-9188d6279746a346888b23503d2ae78f29c978c8.tar.bz2
gentoo-9188d6279746a346888b23503d2ae78f29c978c8.zip
x11-misc/rss-glx: EAPI=7 and cleanup
* Set EAPI=7, split out BDEPEND, EPREFIXify. * Drop unused eclasses (eutils, multilib). * Get rid of static libs and .la files. * Add missing apostrophes to hack names. Signed-off-by: Alexander Miller <alex.miller@gmx.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rss-glx/rss-glx-0.9.1-r2.ebuild51
1 files changed, 29 insertions, 22 deletions
diff --git a/x11-misc/rss-glx/rss-glx-0.9.1-r2.ebuild b/x11-misc/rss-glx/rss-glx-0.9.1-r2.ebuild
index 46625edcea17..61300f4958c1 100644
--- a/x11-misc/rss-glx/rss-glx-0.9.1-r2.ebuild
+++ b/x11-misc/rss-glx/rss-glx-0.9.1-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils multilib
+EAPI=7
+
+inherit autotools
MY_P=${PN}_${PV}
@@ -24,17 +25,16 @@ RDEPEND="
>=x11-misc/xscreensaver-5.08-r2
bzip2? ( app-arch/bzip2 )
openal? ( >=media-libs/freealut-1.1.0-r1 )
- quesoglc? ( media-libs/quesoglc )
-"
+ quesoglc? ( media-libs/quesoglc )"
DEPEND="
${RDEPEND}
- x11-base/xorg-proto
+ x11-base/xorg-proto"
+BDEPEND="
virtual/pkgconfig
- sys-apps/sed
-"
+ bzip2? ( app-arch/bzip2 )"
+
+S="${WORKDIR}/${MY_P}"
-DOCS="ChangeLog README*"
-S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}"/${P}-quesoglc.patch
"${FILESDIR}"/${P}-asneeded.patch
@@ -50,24 +50,31 @@ src_prepare() {
-e '/CXXFLAGS=/s:-O2:${CXXFLAGS}:' \
-e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
configure.in || die
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf \
+ --disable-static \
+ --enable-shared \
$(use_enable bzip2) \
$(use_enable openal sound) \
$(use_with quesoglc) \
- --bindir=/usr/$(get_libdir)/misc/xscreensaver \
- --enable-shared \
- --with-configdir=/usr/share/xscreensaver/config
+ --bindir="${EPREFIX}"/usr/$(get_libdir)/misc/xscreensaver \
+ --with-configdir="${EPREFIX}"/usr/share/xscreensaver/config
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
- local xssconf="${ROOT}usr/share/X11/app-defaults/XScreenSaver"
+ local xssconf="${EROOT}"/usr/share/X11/app-defaults/XScreenSaver
- if [ -f ${xssconf} ]; then
+ if [[ -f ${xssconf} ]]; then
sed -e '/*programs:/a\
GL: \"Cyclone\" cyclone --root \\n\\\
GL: \"Euphoria\" euphoria --root \\n\\\
@@ -82,8 +89,8 @@ pkg_postinst() {
GL: \"Skyrocket\" skyrocket --root \\n\\\
GL: \"Solarwinds\" solarwinds --root \\n\\\
GL: \"Colorfire\" colorfire --root \\n\\\
- GL: \"Hufos Smoke\" hufo_smoke --root \\n\\\
- GL: \"Hufos Tunnel\" hufo_tunnel --root \\n\\\
+ GL: \"Hufo\x27s Smoke\" hufo_smoke --root \\n\\\
+ GL: \"Hufo\x27s Tunnel\" hufo_tunnel --root \\n\\\
GL: \"Sundancer2\" sundancer2 --root \\n\\\
GL: \"BioF\" biof --root \\n\\\
GL: \"BusySpheres\" busyspheres --root \\n\\\
@@ -92,14 +99,14 @@ pkg_postinst() {
GL: \"Lorenz\" lorenz --root \\n\\\
GL: \"Drempels\" drempels --root \\n\\\
GL: \"Feedback\" feedback --root \\n\\' \
- -i ${xssconf} || die
+ -i "${xssconf}" || die
fi
}
pkg_postrm() {
- local xssconf="${ROOT}usr/share/X11/app-defaults/XScreenSaver"
+ local xssconf="${EROOT}"/usr/share/X11/app-defaults/XScreenSaver
- if [ -f ${xssconf} ]; then
+ if [[ -f ${xssconf} ]]; then
sed \
-e '/\"Cyclone\" cyclone/d' \
-e '/\"Euphoria\" euphoria/d' \
@@ -114,8 +121,8 @@ pkg_postrm() {
-e '/\"Skyrocket\" skyrocket/d' \
-e '/\"Solarwinds\" solarwinds/d' \
-e '/\"Colorfire\" colorfire/d' \
- -e '/\"Hufos Smoke\" hufo_smoke/d' \
- -e '/\"Hufos Tunnel\" hufo_tunnel/d' \
+ -e '/\"Hufo.*Smoke\" hufo_smoke/d' \
+ -e '/\"Hufo.*Tunnel\" hufo_tunnel/d' \
-e '/\"Sundancer2\" sundancer2/d' \
-e '/\"BioF\" biof/d' \
-e '/\"BusySpheres\" busyspheres/d' \
@@ -124,6 +131,6 @@ pkg_postrm() {
-e '/\"Lorenz\" lorenz/d' \
-e '/\"Drempels\" drempels/d' \
-e '/\"Feedback\" feedback/d' \
- -i ${xssconf} || die
+ -i "${xssconf}" || die
fi
}