summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-01 05:01:40 +0000
committerSam James <sam@gentoo.org>2020-11-01 05:02:06 +0000
commit645b62c84d25e8d90617e53cd62b5cf9bc1b2ac3 (patch)
tree91a233a11f9849acb80f16f6d15c65007b8262d8 /x11-plugins/asmon
parentsys-process/parallel: add ~ppc64 keyword (diff)
downloadgentoo-645b62c84d25e8d90617e53cd62b5cf9bc1b2ac3.tar.gz
gentoo-645b62c84d25e8d90617e53cd62b5cf9bc1b2ac3.tar.bz2
gentoo-645b62c84d25e8d90617e53cd62b5cf9bc1b2ac3.zip
x11-plugins/asmon: fix build with gcc 10
Closes: https://bugs.gentoo.org/708118 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/asmon')
-rw-r--r--x11-plugins/asmon/asmon-0.71-r1.ebuild18
-rw-r--r--x11-plugins/asmon/files/asmon-0.71-fno-common.patch22
-rw-r--r--x11-plugins/asmon/files/asmon-0.71-list.patch10
3 files changed, 36 insertions, 14 deletions
diff --git a/x11-plugins/asmon/asmon-0.71-r1.ebuild b/x11-plugins/asmon/asmon-0.71-r1.ebuild
index 2c91504fc699..2d2ce19ee4ef 100644
--- a/x11-plugins/asmon/asmon-0.71-r1.ebuild
+++ b/x11-plugins/asmon/asmon-0.71-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="WindowMaker/AfterStep system monitor dockapp"
HOMEPAGE="http://rio.vg/asmon"
SRC_URI="http://rio.vg/${PN}/${P}.tar.bz2"
+S="${WORKDIR}/${P}/${PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc sparc x86"
-IUSE=""
RDEPEND="x11-libs/libXext
x11-libs/libXpm
@@ -19,13 +20,14 @@ RDEPEND="x11-libs/libXext
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-S=${WORKDIR}/${P}/${PN}
-
src_prepare() {
+ default
+
sed -i -e "s:gcc:$(tc-getCC):g" Makefile || die
- cd "${WORKDIR}"/${P} || die
- epatch "${FILESDIR}"/${P}-list.patch
+ cd "../wmgeneral" || die
+ eapply "${FILESDIR}/${P}-list.patch"
+ eapply "${FILESDIR}/${P}-fno-common.patch"
}
src_compile() {
diff --git a/x11-plugins/asmon/files/asmon-0.71-fno-common.patch b/x11-plugins/asmon/files/asmon-0.71-fno-common.patch
new file mode 100644
index 000000000000..831d6b258163
--- /dev/null
+++ b/x11-plugins/asmon/files/asmon-0.71-fno-common.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/708118
+--- a/wmgeneral.c
++++ b/wmgeneral.c
+@@ -50,6 +50,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+--- a/wmgeneral.h
++++ b/wmgeneral.h
+@@ -28,7 +28,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/asmon/files/asmon-0.71-list.patch b/x11-plugins/asmon/files/asmon-0.71-list.patch
index 1b1ac317669e..89e9ef321673 100644
--- a/x11-plugins/asmon/files/asmon-0.71-list.patch
+++ b/x11-plugins/asmon/files/asmon-0.71-list.patch
@@ -1,6 +1,5 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
+--- a/list.c
++++ b/list.c
@@ -38,7 +38,7 @@
/* Return a cons cell produced from (head . tail)
@@ -82,9 +81,8 @@ diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
list_mapcar(LinkedList* list, void(*function)(void*))
{
while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
+--- a/list.h
++++ b/list.h
@@ -29,31 +29,25 @@
#ifndef __LIST_H_
#define __LIST_H_