summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-04-04 13:42:06 +0200
committerSam James <sam@gentoo.org>2022-04-21 20:54:38 +0100
commited5040037d97726d76f6bad5a062547784ad12d5 (patch)
tree9e2aa607875dfa76a2a5eff627e749f7e089bd6e /x11-plugins/gkrellm-radio
parentx11-plugins/gkrellm-bgchanger: update EAPI 6 -> 8 (diff)
downloadgentoo-ed5040037d97726d76f6bad5a062547784ad12d5.tar.gz
gentoo-ed5040037d97726d76f6bad5a062547784ad12d5.tar.bz2
gentoo-ed5040037d97726d76f6bad5a062547784ad12d5.zip
x11-plugins/gkrellm-radio: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellm-radio')
-rw-r--r--x11-plugins/gkrellm-radio/files/gkrellm-radio-2.0.4-r1-pkgconfig.patch15
-rw-r--r--x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4-r1.ebuild36
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-radio/files/gkrellm-radio-2.0.4-r1-pkgconfig.patch b/x11-plugins/gkrellm-radio/files/gkrellm-radio-2.0.4-r1-pkgconfig.patch
new file mode 100644
index 000000000000..94405dc469df
--- /dev/null
+++ b/x11-plugins/gkrellm-radio/files/gkrellm-radio-2.0.4-r1-pkgconfig.patch
@@ -0,0 +1,15 @@
+Respect user's pkg-config
+--- a/Makefile
++++ b/Makefile
+@@ -15,8 +15,9 @@ OBJS=gkrellm_radio.o radio.o
+ PLUGIN_DIR ?= /usr/local/lib/gkrellm2/plugins
+ INSTALL = install -c
+ INSTALL_PROGRAM = $(INSTALL) -s
+-GTK_CONFIG = pkg-config gtk+-2.0
+-CFLAGS := ${CFLAGS} -fPIC -I$(GKRELLMDIR)/include `$(GTK_CONFIG) --cflags` -DVERSION=\"$(VERSION)\" -Wall
++PKG_CONFIG ?= pkg-config
++GTK_INCLUDE = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++CFLAGS := ${CFLAGS} -fPIC -I$(GKRELLMDIR)/include ${GTK_INCLUDE} -DVERSION=\"$(VERSION)\" -Wall
+
+ ifdef WITH_LIRC
+ CFLAGS := ${CFLAGS} -DHAVE_LIRC
diff --git a/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4-r1.ebuild b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..d5fcf32c4c2f
--- /dev/null
+++ b/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners"
+HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.php"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="lirc"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ lirc? ( app-misc/lirc )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-r1-pkgconfig.patch
+)
+
+src_configure() {
+ PLUGIN_SO=( radio$(get_modname) )
+ default
+}
+
+src_compile() {
+ use lirc && myconf="${myconf} WITH_LIRC=1"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}
+}