summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-11 22:17:31 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-14 11:01:07 +0200
commitd52abe88f3211bf2109f7c9b470250cae1929145 (patch)
treeed89448df45ea63bc1450f7696e3adce6e87dd70 /x11-plugins/wmSMPmon
parentx11-plugins/wmSMPmon: use HTTPS (diff)
downloadgentoo-d52abe88f3211bf2109f7c9b470250cae1929145.tar.gz
gentoo-d52abe88f3211bf2109f7c9b470250cae1929145.tar.bz2
gentoo-d52abe88f3211bf2109f7c9b470250cae1929145.zip
x11-plugins/wmSMPmon: EAPI7, use HTTPS, improve ebuild
Diffstat (limited to 'x11-plugins/wmSMPmon')
-rw-r--r--x11-plugins/wmSMPmon/files/wmSMPmon-3.1-makefile.patch4
-rw-r--r--x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild31
2 files changed, 33 insertions, 2 deletions
diff --git a/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-makefile.patch b/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-makefile.patch
index 1bd27f47c0f1..3dd1b0636d86 100644
--- a/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-makefile.patch
+++ b/x11-plugins/wmSMPmon/files/wmSMPmon-3.1-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2005-02-22 23:24:23.000000000 +0100
-+++ Makefile 2008-01-28 00:12:33.000000000 +0100
+--- a/Makefile 2005-02-22 23:24:23.000000000 +0100
++++ b/Makefile 2008-01-28 00:12:33.000000000 +0100
@@ -2,22 +2,24 @@
# Adapted for wmSMPmon 2.9.x and higher: Thomas Ribbrock
diff --git a/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
new file mode 100644
index 000000000000..5ec664e00fd4
--- /dev/null
+++ b/x11-plugins/wmSMPmon/wmSMPmon-3.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SMP system monitor dockapp"
+HOMEPAGE="https://www.dockapps.net/wmsmpmon"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( ../Changelog )
+
+S="${WORKDIR}/${P}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}