summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmdrawer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmdrawer')
-rw-r--r--x11-plugins/wmdrawer/Manifest1
-rw-r--r--x11-plugins/wmdrawer/files/wmdrawer-0.10.5-gtk+-2.patch14
-rw-r--r--x11-plugins/wmdrawer/metadata.xml9
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild42
4 files changed, 66 insertions, 0 deletions
diff --git a/x11-plugins/wmdrawer/Manifest b/x11-plugins/wmdrawer/Manifest
new file mode 100644
index 000000000000..36159c458456
--- /dev/null
+++ b/x11-plugins/wmdrawer/Manifest
@@ -0,0 +1 @@
+DIST wmdrawer-0.10.5.tar.gz 49413 SHA256 1fd727ce9d91abe1e0c12ad82dbaa9b3aa69f4b852af460ac81c32a7394c5078
diff --git a/x11-plugins/wmdrawer/files/wmdrawer-0.10.5-gtk+-2.patch b/x11-plugins/wmdrawer/files/wmdrawer-0.10.5-gtk+-2.patch
new file mode 100644
index 000000000000..f378c73400ba
--- /dev/null
+++ b/x11-plugins/wmdrawer/files/wmdrawer-0.10.5-gtk+-2.patch
@@ -0,0 +1,14 @@
+diff -ur wmdrawer-0.10.5/Makefile wmdrawer-0.10.5~/Makefile
+--- wmdrawer-0.10.5/Makefile 2004-06-26 20:16:04.000000000 +0200
++++ wmdrawer-0.10.5~/Makefile 2005-03-25 22:08:08.000000000 +0100
+@@ -16,8 +16,8 @@
+ DOCDIR = $(PREFIX)/share/doc
+
+ # Image library
+-USE_GDKPIXBUF = 1
+-#USE_GDKPIXBUF2 = 1
++#USE_GDKPIXBUF = 1
++USE_GDKPIXBUF2 = 1
+ #USE_IMLIB = 1
+
+ DEFS = $(OS)
diff --git a/x11-plugins/wmdrawer/metadata.xml b/x11-plugins/wmdrawer/metadata.xml
new file mode 100644
index 000000000000..e0d2cdc50f22
--- /dev/null
+++ b/x11-plugins/wmdrawer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmDrawer is a dockapp which provides a drawer
+(button bar) from which applications can be launched.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
new file mode 100644
index 000000000000..5bf6cba5b4b6
--- /dev/null
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="dockapp which provides a drawer (retractable button bar) to launch applications"
+HOMEPAGE="http://people.easter-eggs.org/~valos/wmdrawer/"
+SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk+-2.patch
+
+ # Honour Gentoo CFLAGS
+ sed -i -e "s|-O3|${CFLAGS}|" Makefile || die
+ # Fix LDFLAGS ordering per bug #248640
+ sed -i -e 's/$(CC) $(LDFLAGS) -o $@ $(OBJS)/$(CC) -o $@ $(OBJS) $(LDFLAGS)/' Makefile || die
+ # Do not auto-strip binaries
+ sed -i -e 's/ strip $@//' Makefile || die
+ # Honour Gentoo LDFLAGS
+ sed -i -e 's/$(CC) -o/$(CC) $(REAL_LDFLAGS) -o/' Makefile || die
+}
+
+src_compile() {
+ emake REAL_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin wmdrawer
+ dodoc README TODO AUTHORS ChangeLog wmdrawerrc.example
+ doman doc/wmdrawer.1x.gz
+}