summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmmon+smp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmmon+smp')
-rw-r--r--x11-plugins/wmmon+smp/Manifest1
-rw-r--r--x11-plugins/wmmon+smp/metadata.xml11
-rw-r--r--x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/x11-plugins/wmmon+smp/Manifest b/x11-plugins/wmmon+smp/Manifest
new file mode 100644
index 000000000000..99990d6b6b6e
--- /dev/null
+++ b/x11-plugins/wmmon+smp/Manifest
@@ -0,0 +1 @@
+DIST wmmon+smp.tar.gz 15807 SHA256 d8d98323c3c5d091902ed52cae2c0ba9db34b6af11d75d67104c6d90e6b30f96 SHA512 9565815c30642a3d12a23960bf6123eafa9379d24a69b2a75794757e89a3b056669fc47a898a5e756871a74502dcab8b76abe5508f2c5474a1fbfc8bdd4e6a94 WHIRLPOOL 17fcf7b3cf678cda708339f8d4aefdc2c17d8341148dad12b6905622891e61395ba5ed1645f453c7910a30e358b44f9cf53a44cd75e1505db1c47efe5eca3304
diff --git a/x11-plugins/wmmon+smp/metadata.xml b/x11-plugins/wmmon+smp/metadata.xml
new file mode 100644
index 000000000000..c19c35269035
--- /dev/null
+++ b/x11-plugins/wmmon+smp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <longdescription>
+WMMon+SMP shows real-time CPU usage on SMP machines. Only Dual-processor
+systems are supported. A load average graph a.k.a. wmloadavg/xload is also
+provided. WMMon+SMP is based on WMMon 1.0b2 and does not display I/O or memory
+statistics.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
new file mode 100644
index 000000000000..8a3c94955f04
--- /dev/null
+++ b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockapp CPU monitor resembling Xosview, support for smp"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/wmmon+smp.tar.gz"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/wmmon.app/wmmon
+
+src_prepare() {
+ # Respect LDFLAGS, see bug #335047
+ sed \
+ -e 's/cc -o/${CC} ${LDFLAGS} -o/' \
+ -e 's/cc -c/${CC} ${CFLAGS} -c/' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install () {
+ newbin wmmon wmmon+smp
+ dodoc ../README
+}