summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmmon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmmon')
-rw-r--r--x11-plugins/wmmon/Manifest2
-rw-r--r--x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26-v2.patch207
-rw-r--r--x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch20
-rw-r--r--x11-plugins/wmmon/metadata.xml5
-rw-r--r--x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild40
-rw-r--r--x11-plugins/wmmon/wmmon-1.2_beta1.ebuild37
6 files changed, 311 insertions, 0 deletions
diff --git a/x11-plugins/wmmon/Manifest b/x11-plugins/wmmon/Manifest
new file mode 100644
index 000000000000..4cebfb4bfe5c
--- /dev/null
+++ b/x11-plugins/wmmon/Manifest
@@ -0,0 +1,2 @@
+DIST wmmon-1.2b1.tar.bz2 25610 RMD160 88d149f377866aec5bd5e2ab0ff683843f14708a SHA1 4e7bda90b3d2ee7dfce216b32f3b701db65dd3f3 SHA256 5b203ec46fe13d5fdee51ec878cf1856704bf650a8f5458416b9cf4585e7cac2
+DIST wmmon-1_0b2.tar.gz 21589 RMD160 23c64f8bf25b0992a2f98dcfa4c24d66330c475b SHA1 96616c653a153861e38945c07095f8ee30bc6479 SHA256 0d34003747b36d47c1f6361675eee982d6eaf458b33f8cf4ecb157e87cdde9bf
diff --git a/x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26-v2.patch b/x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26-v2.patch
new file mode 100644
index 000000000000..38182bb2a907
--- /dev/null
+++ b/x11-plugins/wmmon/files/wmmon-1.0_beta2-kernel26-v2.patch
@@ -0,0 +1,207 @@
+*** wmmon.c Tue May 19 14:13:16 1998
+--- wmmon.c.patched Tue May 10 12:31:40 2005
+***************
+*** 101,107 ****
+ /********************/
+
+ char *ProgName;
+! int stat_current = 0; /* now global */
+ FILE *fp_meminfo;
+ FILE *fp_stat;
+ FILE *fp_loadavg;
+--- 101,108 ----
+ /********************/
+
+ char *ProgName;
+! int stat_current = 0; /* now global */
+! int minus_buffers = 1; /* do we want to subtract buffers and cache from memory usage? */
+ FILE *fp_meminfo;
+ FILE *fp_stat;
+ FILE *fp_loadavg;
+*************** void main(int argc, char *argv[]) {
+*** 146,151 ****
+--- 147,155 ----
+ case 's' :
+ stat_current = 2;
+ break;
++ case 'b' :
++ minus_buffers = 0;
++ break;
+ default:
+ usage();
+ exit(0);
+*************** void DrawActive(char *);
+*** 188,194 ****
+ void update_stat_cpu(stat_dev *);
+ void update_stat_io(stat_dev *);
+ void update_stat_mem(stat_dev *st, stat_dev *st2);
+- void update_stat_swp(stat_dev *);
+
+ void wmmon_routine(int argc, char **argv) {
+
+--- 192,197 ----
+*************** void wmmon_routine(int argc, char **argv
+*** 298,304 ****
+
+ if(stat_current == 2) {
+ update_stat_mem(&stat_device[2], &stat_device[3]);
+- // update_stat_swp(&stat_device[3]);
+ }
+
+ if (stat_current < 2) {
+--- 301,306 ----
+*************** void wmmon_routine(int argc, char **argv
+*** 320,341 ****
+ copyXPMArea(0, 64, 32, 12, 28+64, 4);
+ copyXPMArea(0, 64, 32, 12, 28+64, 18);
+
+! j = stat_device[2].rt_idle;
+! if (j != 0) {
+! j = (stat_device[2].rt_stat * 100) / j;
+! }
+! j = j * 0.32;
+! if (j > 32) j = 32;
+! copyXPMArea(32, 64, j, 12, 28+64, 4);
+! /*--------------------- ------------------*/
+! j = stat_device[3].rt_idle;
+! if (j != 0) {
+! j = (stat_device[3].rt_stat * 100) / j;
+ }
+- j = j * 0.32;
+- if (j > 32) j = 32;
+- copyXPMArea(32, 64, j, 12, 28+64, 18);
+-
+ /*----------- online tijd neerzetten! ----------*/
+
+ cnt_time = time(0) - ref_time + online_time;
+--- 322,335 ----
+ copyXPMArea(0, 64, 32, 12, 28+64, 4);
+ copyXPMArea(0, 64, 32, 12, 28+64, 18);
+
+! for (i = 2; i <= 3; i++) {
+! j = stat_device[i].rt_stat != 0
+! ? 100 * ( stat_device[i].rt_stat - stat_device[i].rt_idle ) / stat_device[i].rt_stat
+! : 0 ;
+! j = j * 0.32;
+! if (j > 32) j = 32;
+! copyXPMArea(32, 64, j, 12, 28+64, 4+(14*(i-2)) );
+ }
+ /*----------- online tijd neerzetten! ----------*/
+
+ cnt_time = time(0) - ref_time + online_time;
+*************** void wmmon_routine(int argc, char **argv
+*** 430,436 ****
+ }
+ case 1:
+ stat_current++;
+- printf("current stat is :%d\n", stat_current);
+ if (stat_current == stat_online)
+ stat_current = 0;
+
+--- 424,429 ----
+*************** void update_stat_io(stat_dev *st) {
+*** 499,541 ****
+
+ void update_stat_mem(stat_dev *st, stat_dev *st2) {
+
+! char temp[128];
+! unsigned long free, shared, buffers, cached;
+
+ freopen("/proc/meminfo", "r", fp_meminfo);
+ while (fgets(temp, 128, fp_meminfo)) {
+! if (strstr(temp, "Mem:")) {
+! sscanf(temp, "Mem: %ld %ld %ld %ld %ld %ld",
+! &st->rt_idle, &st->rt_stat,
+! &free, &shared, &buffers, &cached);
+! st->rt_idle >>= 10;
+! st->rt_stat -= buffers+cached;
+! st->rt_stat >>= 10;
+! // break;
+ }
+! if (strstr(temp, "Swap:")) {
+! sscanf(temp, "Swap: %ld %ld", &st2->rt_idle, &st2->rt_stat);
+! st2->rt_idle >>= 10;
+! st2->rt_stat >>= 10;
+! break;
+ }
+! }
+! }
+!
+! void update_stat_swp(stat_dev *st) {
+!
+! char temp[128];
+!
+! fseek(fp_meminfo, 0, SEEK_SET);
+! while (fgets(temp, 128, fp_meminfo)) {
+! if (strstr(temp, "Swap:")) {
+! sscanf(temp, "Swap: %ld %ld", &st->rt_idle, &st->rt_stat);
+! st->rt_idle >>= 10;
+! st->rt_stat >>= 10;
+! break;
+ }
+ }
+-
+ }
+
+ /*******************************************************************************\
+--- 492,523 ----
+
+ void update_stat_mem(stat_dev *st, stat_dev *st2) {
+
+! char temp[128], stat[20];
+! unsigned long amount;
+
+ freopen("/proc/meminfo", "r", fp_meminfo);
++ st->rt_idle = 0; /* zero this out so we can +/- appropriately */
+ while (fgets(temp, 128, fp_meminfo)) {
+! sscanf(temp, "%s %ld", &stat, &amount);
+! if (! strcmp(stat, "MemFree:") ) {
+! st->rt_idle += (amount >> 10);
+ }
+! else if (! strcmp(stat, "MemTotal:") ) {
+! st->rt_stat = (amount >> 10);
+ }
+! else if (! strcmp(stat, "Buffers:") && minus_buffers ) {
+! st->rt_idle += (amount >> 10);
+! }
+! else if (! strcmp(stat, "Cached:") && minus_buffers ) {
+! st->rt_idle += (amount >> 10);
+! }
+! else if (! strcmp(stat, "SwapFree:") ) {
+! st2->rt_idle = (amount >> 10);
+! }
+! else if (! strcmp(stat, "SwapTotal:") ) {
+! st2->rt_stat = (amount >> 10);
+ }
+ }
+ }
+
+ /*******************************************************************************\
+*************** int checksysdevs(void) {
+*** 599,605 ****
+
+ strcpy(stat_device[0].name, "cpu0");
+ strcpy(stat_device[1].name, "i/o");
+! strcpy(stat_device[2].name, "sys");
+
+ return 3;
+ }
+--- 581,588 ----
+
+ strcpy(stat_device[0].name, "cpu0");
+ strcpy(stat_device[1].name, "i/o");
+! strcpy(stat_device[2].name, "mem");
+! strcpy(stat_device[3].name, "swap");
+
+ return 3;
+ }
+*************** void usage(void) {
+*** 724,729 ****
+--- 707,713 ----
+ fprintf(stderr, "\t-v\tprint the version number\n");
+ fprintf(stderr, "\t-i\tstartup in DiskIO mode\n");
+ fprintf(stderr, "\t-s\tstartup in SysInfo mode\n");
++ fprintf(stderr, "\t-b\tdo not subtract buffer and cache from memory usage\n");
+ fprintf(stderr, "\n");
+ }
+
diff --git a/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch b/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch
new file mode 100644
index 000000000000..c7633ad7388b
--- /dev/null
+++ b/x11-plugins/wmmon/files/wmmon-1.2_beta1-Makefile.patch
@@ -0,0 +1,20 @@
+--- wmmon/Makefile.orig 2012-03-29 13:17:39.380764054 +0200
++++ wmmon/Makefile 2012-03-29 13:18:06.623931767 +0200
+@@ -6,14 +6,14 @@
+ ../wmgeneral/list.o
+
+ CFLAGS = -O2
+-CC = cc $(CFLAGS)
++CC = cc
+
+
+ .c.o:
+- $(CC) -c -Wall $< -o $*.o
++ $(CC) $(CFLAGS) -c -Wall $< -o $*.o
+
+ wmmon: $(OBJS)
+- $(CC) -o wmmon $^ $(LIBDIR) $(LIBS)
++ $(CC) $(LDFLAGS) -o wmmon $^ $(LIBDIR) $(LIBS)
+
+ debug: CFLAGS = -g3
+ debug: wmmon
diff --git a/x11-plugins/wmmon/metadata.xml b/x11-plugins/wmmon/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmmon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild b/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild
new file mode 100644
index 000000000000..b887f53ad232
--- /dev/null
+++ b/x11-plugins/wmmon/wmmon-1.0_beta2-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+S=${WORKDIR}/${PN}.app
+IUSE=""
+DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
+WMMON_VERSION=1_0b2
+SRC_URI="http://rpig.dyndns.org/~anstinus/Linux/${PN}-${WMMON_VERSION}.tar.gz"
+HOMEPAGE="http://www.bensinclair.com/dockapp/"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ >=sys-apps/sed-4"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/${PN}
+ epatch "${FILESDIR}"/${P}-kernel26-v2.patch
+ sed -i -e "s|-O2|${CFLAGS}|" Makefile
+ sed -i -e "s|cc -o wmmon|cc ${LDFLAGS} -o wmmon|" Makefile
+}
+
+src_compile() {
+ emake -C ${PN} || die
+}
+
+src_install () {
+ dobin wmmon/wmmon
+ dodoc BUGS CHANGES HINTS README TODO
+}
diff --git a/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild b/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild
new file mode 100644
index 000000000000..009a86d08f86
--- /dev/null
+++ b/x11-plugins/wmmon/wmmon-1.2_beta1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
+HOMEPAGE="http://repo.or.cz/w/dockapps.git"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P/_beta/b}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P/_beta/b}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C ${PN}
+}
+
+src_install () {
+ dobin wmmon/wmmon
+ doman wmmon/wmmon.1
+ dodoc BUGS CHANGES HINTS README TODO
+}