summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmweather
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmweather')
-rw-r--r--x11-plugins/wmweather/Manifest2
-rw-r--r--x11-plugins/wmweather/metadata.xml12
-rw-r--r--x11-plugins/wmweather/wmweather-2.4.4.ebuild28
-rw-r--r--x11-plugins/wmweather/wmweather-2.4.5.ebuild29
4 files changed, 71 insertions, 0 deletions
diff --git a/x11-plugins/wmweather/Manifest b/x11-plugins/wmweather/Manifest
new file mode 100644
index 000000000000..30a645543b48
--- /dev/null
+++ b/x11-plugins/wmweather/Manifest
@@ -0,0 +1,2 @@
+DIST wmweather_2.4.4.orig.tar.gz 84773 SHA256 b58de9e4d8755a829108a3a04d1949c81a1c91d9c7e2cdf78a0b62c19b73c3e6
+DIST wmweather_2.4.5.orig.tar.gz 85128 SHA256 1555e2329ca9cb392881260068d8de761a55baf4bb2b5b6eeb9b755b68faf45a SHA512 eb62a6d03875c087e306e83ec2010916da702f942b22b130c327d890daf29803bf01f52fe0e03b962656d0dd9a329696e8fc19238eedc32f5ce72d8929eab87b WHIRLPOOL 4a2fc553e11c9cdd35a10b1901dc18e240cc016d5ce22c403991adc54cc07f1a35e453c6c1ae17ef0ef979b211c681d700e797e42047918618bf2024b9bf6198
diff --git a/x11-plugins/wmweather/metadata.xml b/x11-plugins/wmweather/metadata.xml
new file mode 100644
index 000000000000..e695147fdfff
--- /dev/null
+++ b/x11-plugins/wmweather/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmweather displays your current local weather conditions. After supplying a
+4-character METAR station identifier code (most major airports have one), it
+shows station ID, time of the last update, temperature, dew point, pressure,
+humidity, and wind speed. The various entries can be forced to display in a
+variety of different units.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmweather/wmweather-2.4.4.ebuild b/x11-plugins/wmweather/wmweather-2.4.4.ebuild
new file mode 100644
index 000000000000..df9234882420
--- /dev/null
+++ b/x11-plugins/wmweather/wmweather-2.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a dockable weather monitor for standard METAR stations using ICAO location"
+HOMEPAGE="http://www.godisch.de/debian/wmweather"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-apps/xmessage
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P}/src
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ../{CHANGES,README}
+}
diff --git a/x11-plugins/wmweather/wmweather-2.4.5.ebuild b/x11-plugins/wmweather/wmweather-2.4.5.ebuild
new file mode 100644
index 000000000000..2ffc5618c835
--- /dev/null
+++ b/x11-plugins/wmweather/wmweather-2.4.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+DESCRIPTION="a dockable weather monitor for standard METAR stations using ICAO location"
+HOMEPAGE="http://www.godisch.de/debian/wmweather"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-apps/xmessage
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/${P}/src
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ../{CHANGES,README}
+}