summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-12-06 16:23:07 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-12-06 16:23:07 +0100
commit15d80c2eada2c92fd17f1d6f79f25457dab7397a (patch)
tree38045956701894655ef0ea0abaefe052b55c4474 /x11-plugins
parenteclass/prefix.eclass: use a long line for @USAGE (diff)
downloadgentoo-15d80c2eada2c92fd17f1d6f79f25457dab7397a.tar.gz
gentoo-15d80c2eada2c92fd17f1d6f79f25457dab7397a.tar.bz2
gentoo-15d80c2eada2c92fd17f1d6f79f25457dab7397a.zip
x11-plugins/wmsysmon: 0.7.8 new upstream, new ebuild
This integrates all Gentoo changes, plus kernel >= 3.0 support package.mask is updated to allow this new version in ~arch Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmsysmon/Manifest5
-rw-r--r--x11-plugins/wmsysmon/metadata.xml4
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild31
3 files changed, 37 insertions, 3 deletions
diff --git a/x11-plugins/wmsysmon/Manifest b/x11-plugins/wmsysmon/Manifest
index 01107cd03b17..1ed41e87101f 100644
--- a/x11-plugins/wmsysmon/Manifest
+++ b/x11-plugins/wmsysmon/Manifest
@@ -1,2 +1,3 @@
-DIST wmsysmon-0.7.7-s4t4n.patch.bz2 8547 SHA256 b585793744c65ccc10c0b2b55c34f7c5cf0ac03b99526f50842ace99a1ce7245 SHA512 fbf43af697313c1f2c8c5d373b636b92b87140979c47037c214b2af8e0e94faa1df610e9fb94e677bfd6de94320e1e161ac1b1afbfb665fd7e86849ee93d8e1e WHIRLPOOL 33b3a7478db17d05155e8104c4f89f25defaaf4eadf00622725b39d95e879260f6e319271be7b89d30ee9cb3444d468166ee9a31e89ccd5f86f7d1cedd937170
-DIST wmsysmon-0.7.7.tar.gz 20866 SHA256 b50e3d834e799ff2b2a825c67534e049bed2af2c261d83b8afbbd4a9010d3e5c SHA512 6f472d132c7b5263c4b62e0972653ceee59743c4e292c0bdd95194e84373f4e7888311b40083691ab5b736c0ba292672d8eb306a220e95d356dd95b6b8519c0c WHIRLPOOL cf525c75b576aea805d41bf65315d6909964ff6067d95b79feb84e8617e05a140e6368dc1cd2596e7f7b92f2bb42207315c19b2ad826e44cabf3c1ea97bd25a5
+DIST wmsysmon-0.7.7-s4t4n.patch.bz2 8547 BLAKE2B 7c68524981336630b70a16e4e2935790dc246e40c7c16cedf2487e5145cebec797569042b5234b334988cec836878625ce631de4ff9cb8588e921a7d20c5d904 SHA512 fbf43af697313c1f2c8c5d373b636b92b87140979c47037c214b2af8e0e94faa1df610e9fb94e677bfd6de94320e1e161ac1b1afbfb665fd7e86849ee93d8e1e
+DIST wmsysmon-0.7.7.tar.gz 20866 BLAKE2B ddccccf05a5d54214336f58fe3c4cf8631da11098a2a8a42677b51e20414fbeb9dd4a8ec02c92cd8933635973470d56c2837b6ab41bb07348f39946f8b94dcfa SHA512 6f472d132c7b5263c4b62e0972653ceee59743c4e292c0bdd95194e84373f4e7888311b40083691ab5b736c0ba292672d8eb306a220e95d356dd95b6b8519c0c
+DIST wmsysmon-0.7.8.tar.gz 23533 BLAKE2B 830edc78222e8997c6ee23bdd9fcb28729e9b80d92b07f70a53d841065b7377f5c450024c511b4faa92043bd45aa0cc92e89ff900d7d4a53d3c9f4b57b4e6e7e SHA512 b1afd176851e8f89896e39b55d24d6efeb97eb5fdbb9c181cb030320445f1d8b22d31073edc615e6b47b91fd133b381f00b612901c8b312e7da404a4746bb97c
diff --git a/x11-plugins/wmsysmon/metadata.xml b/x11-plugins/wmsysmon/metadata.xml
index 32d76dd54300..efaca79dc2c7 100644
--- a/x11-plugins/wmsysmon/metadata.xml
+++ b/x11-plugins/wmsysmon/metadata.xml
@@ -5,9 +5,11 @@
<email>voyageur@gentoo.org</email>
<name>Bernard Cafarelli</name>
</maintainer>
-
<use>
<flag name="high-ints">Enable support for monitoring 24 interrupts. Useful
on SMP machines</flag>
</use>
+<upstream>
+ <remote-id type="github">voyageur/wmsysmon</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild
new file mode 100644
index 000000000000..03c80f8de230
--- /dev/null
+++ b/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
+HOMEPAGE="https://github.com/voyageur/wmsysmon"
+SRC_URI="https://github.com/voyageur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+DOCS=( ../ChangeLog ../README )
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin wmsysmon
+ einstalldocs
+}