summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2017-12-17 12:05:36 +0000
committerIan Whyman <thev00d00@gentoo.org>2017-12-17 12:05:52 +0000
commitbcbaee13aa6324a78abcefa8e349a9ac376c1525 (patch)
treeec98bfc7620376ee0d40bc0cdf68f312a88e94fb /x11-plugins
parentnet-vpn/tor: remove orphaned files, bug #640466 (diff)
downloadgentoo-bcbaee13aa6324a78abcefa8e349a9ac376c1525.tar.gz
gentoo-bcbaee13aa6324a78abcefa8e349a9ac376c1525.tar.bz2
gentoo-bcbaee13aa6324a78abcefa8e349a9ac376c1525.zip
x11-plugins/pidgin-sipe: Version Bump
Thanks to Luke Bratch for the inital ebuild. Closes: https://bugs.gentoo.org/640994 Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-sipe/Manifest1
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.23.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-sipe/Manifest b/x11-plugins/pidgin-sipe/Manifest
index 61e1bb753e4c..b94d2f967e6b 100644
--- a/x11-plugins/pidgin-sipe/Manifest
+++ b/x11-plugins/pidgin-sipe/Manifest
@@ -1,3 +1,4 @@
DIST pidgin-sipe-1.21.1.tar.gz 1212621 BLAKE2B f2fb149a867af1771987857e90eccd0cc9a9624749eafb101b3f1c4e956c63e4f43c237a86925af34a8db81e03b287b1972e19e2bb1315959eb1cb606ef485bb SHA512 d9b5ad67967c35e29d6742d9d09346c7702a339450de7522aad73f0b379505f24104a306292ee91960c679498073376081479b335eab8eba090e492f444b5378
DIST pidgin-sipe-1.22.0.tar.gz 1255851 BLAKE2B 442206854bc420f8a93a34246f28a923adc83c08a9c113d871f920799e2b33505a14b4181d1b20aa65e03c6d6483b01be22e66ed4496ea8571247bfc560d2a97 SHA512 4135bbf526659663b0b053592d889588574ed2a1bc9346e6ba62960203409e2604552ffb02ed32e2b4bb46c4f40f62089302b301344b9f7b45657e64a585f7ed
DIST pidgin-sipe-1.22.1.tar.gz 1265440 BLAKE2B 88f5ef6473af2b50aab0d2adfb9bccf62c9654a1d80319d5e8e43b18719e875e0b3fda45a76e85a6fd892fd516dcfbf5f5ec4a134b1525972eaf35b9841d5210 SHA512 1fff886b32f7f8cb99a0af710b3a1502f62d27dedb541a9e2d8ae9eaf5eb7be0983216e730ccc912c20eee3d940ed1f789f704ee21736db76d141efda66ec018
+DIST pidgin-sipe-1.23.0.tar.gz 1296050 BLAKE2B 1c69587ab6407b6c83dda349ab9a5ad61e3e1d8936b58d7edd71cbead3f8573ab60f7e95866968ec55163a533077be268d6166354d9d22cd2110e6b2ae1708c0 SHA512 8ed0c353e83707b99059791b97568d874634eb1d5ec1a43031864cc8469dc859e7485eb617fe5e23960c091fb15334a903452827ef8a650ed4d677f3a2222cef
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.23.0.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.23.0.ebuild
new file mode 100644
index 000000000000..0f84cb3d0a0b
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.23.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="dbus debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/libxml2
+ openssl? ( dev-libs/openssl:= )
+ !openssl? ( dev-libs/nss )
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:1.0
+ net-libs/farstream:0.2
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ )
+ net-im/pidgin[dbus?]
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ $(use_enable telepathy) \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with dbus) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv) \
+ $(use_enable !openssl nss) \
+ $(use_enable openssl)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}