summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 12:53:25 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 12:53:25 +0100
commitb6c8f92eaee6c4efeb410e069b23b8bafeb62e2e (patch)
tree59d5ccc55c0e1c7add440caf102b7c4efa776b50 /x11-themes
parentx11-themes/tactile3: Port to EAPI 7 (diff)
downloadgentoo-b6c8f92eaee6c4efeb410e069b23b8bafeb62e2e.tar.gz
gentoo-b6c8f92eaee6c4efeb410e069b23b8bafeb62e2e.tar.bz2
gentoo-b6c8f92eaee6c4efeb410e069b23b8bafeb62e2e.zip
x11-themes/tangerine-icon-theme: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/tangerine-icon-theme/files/tangerine-icon-theme-0.27-libexec.patch11
-rw-r--r--x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild36
2 files changed, 30 insertions, 17 deletions
diff --git a/x11-themes/tangerine-icon-theme/files/tangerine-icon-theme-0.27-libexec.patch b/x11-themes/tangerine-icon-theme/files/tangerine-icon-theme-0.27-libexec.patch
new file mode 100644
index 000000000000..4ca0b88c8c13
--- /dev/null
+++ b/x11-themes/tangerine-icon-theme/files/tangerine-icon-theme-0.27-libexec.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+
+ # run icon-naming-utils
+ for d in $$DESTDIR/usr/share/icons/Tangerine/*; do \
+- (cd $$d; for c in *; do /usr/lib/icon-naming-utils/icon-name-mapping -c $$c; done); \
++ (cd $$d; for c in *; do /usr/libexec/icon-name-mapping -c $$c; done); \
+ done
+
+ # install mo files
diff --git a/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
index 457528857ffc..365c0df59781 100644
--- a/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
+++ b/x11-themes/tangerine-icon-theme/tangerine-icon-theme-0.27.ebuild
@@ -1,37 +1,43 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit gnome2-utils
+EAPI=7
+
+inherit xdg
DESCRIPTION="a derivative of the standard Tango theme, using a more orange approach"
HOMEPAGE="http://packages.ubuntu.com/gutsy/x11/tangerine-icon-theme"
-SRC_URI="mirror://ubuntu/pool/universe/t/${PN}/${PN}_${PV}.tar.gz
+SRC_URI="
+ mirror://ubuntu/pool/universe/t/${PN}/${PN}_${PV}.tar.gz
https://www.gentoo.org/images/gentoo-logo.svg"
LICENSE="CC-BY-SA-2.5 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="minimal"
-
RESTRICT="binchecks strip"
-RDEPEND="!minimal? ( || ( x11-themes/adwaita-icon-theme kde-frameworks/oxygen-icons ) )"
-DEPEND="dev-util/intltool
- >=gnome-base/librsvg-2.34
+RDEPEND="
+ !minimal? (
+ || (
+ x11-themes/adwaita-icon-theme
+ kde-frameworks/oxygen-icons
+ )
+ )"
+BDEPEND="
+ dev-util/intltool
+ gnome-base/librsvg
sys-devel/gettext
- >=x11-misc/icon-naming-utils-0.8.90"
+ x11-misc/icon-naming-utils"
-DOCS="AUTHORS README"
+PATCHES=( "${FILESDIR}"/${PN}-0.27-libexec.patch )
src_unpack() {
unpack ${PN}_${PV}.tar.gz
}
src_prepare() {
- sed -i \
- -e 's:lib/icon-naming-utils/icon:libexec/icon:' \
- Makefile || die
+ xdg_src_prepare
cp "${DISTDIR}"/gentoo-logo.svg scalable/places/start-here.svg || die
@@ -45,7 +51,3 @@ src_prepare() {
src_compile() {
emake index.theme
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }