summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-04-14 17:09:53 +0200
committerAaron Bauman <bman@gentoo.org>2018-04-14 14:47:09 -0400
commitef227b56a0e6f8ca917628a5274114fb0d2c4709 (patch)
tree5411b4d1296057a2a5b75dc041954f957f366e84 /x11-wm/selectwm
parentdev-java/commons-math: amd64 stable (diff)
downloadgentoo-ef227b56a0e6f8ca917628a5274114fb0d2c4709.tar.gz
gentoo-ef227b56a0e6f8ca917628a5274114fb0d2c4709.tar.bz2
gentoo-ef227b56a0e6f8ca917628a5274114fb0d2c4709.zip
x11-wm/selectwm: EAPI6, use HTTPS, update patch, update LICENSE
Closes: https://github.com/gentoo/gentoo/pull/7717
Diffstat (limited to 'x11-wm/selectwm')
-rw-r--r--x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch4
-rw-r--r--x11-wm/selectwm/selectwm-0.4.1-r1.ebuild38
-rw-r--r--x11-wm/selectwm/selectwm-0.4.1.ebuild6
3 files changed, 43 insertions, 5 deletions
diff --git a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch b/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
index d5300c9f94a7..4287ca2d2cbb 100644
--- a/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
+++ b/x11-wm/selectwm/files/selectwm-0.4.1-nostrip.patch
@@ -2,8 +2,8 @@ Respect CFLAGS, don't strip binaries
http://bugs.gentoo.org/show_bug.cgi?id=252124
---- src/Makefile.am
-+++ src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -10,5 +10,6 @@
modify.c modify.h \
misc.h define.h
diff --git a/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild b/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..c5ee2b776caa
--- /dev/null
+++ b/x11-wm/selectwm/selectwm-0.4.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="window manager selector tool"
+HOMEPAGE="https://ordiluc.net/selectwm"
+SRC_URI="https://ordiluc.net/selectwm/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DOCS=( AUTHORS README sample.xinitrc )
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-enable-deprecated-gtk.patch"
+ "${FILESDIR}/${P}-glibc-2.10.patch"
+ "${FILESDIR}/${P}-nostrip.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --program-suffix=2 \
+ $(use_enable nls)
+}
diff --git a/x11-wm/selectwm/selectwm-0.4.1.ebuild b/x11-wm/selectwm/selectwm-0.4.1.ebuild
index ac8889b0e7ff..2d148c699075 100644
--- a/x11-wm/selectwm/selectwm-0.4.1.ebuild
+++ b/x11-wm/selectwm/selectwm-0.4.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit autotools eutils
DESCRIPTION="window manager selector tool"
-HOMEPAGE="http://ordiluc.net/selectwm"
-SRC_URI="http://ordiluc.net/selectwm/${P}.tar.bz2"
+HOMEPAGE="https://ordiluc.net/selectwm"
+SRC_URI="https://ordiluc.net/selectwm/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="2"