summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-09-15 22:07:12 +0800
committerJason Zaman <perfinion@gentoo.org>2016-09-15 22:07:47 +0800
commitb719d5d8faffa4b6b780e5cf283996de5896654f (patch)
tree2b32d519261aa4d7a3ff6d578057bd5834da8976 /xfce-extra/xfce4-clipman-plugin
parentxfce-base/xfce4-settings: bump to 4.12.1 (diff)
downloadgentoo-b719d5d8faffa4b6b780e5cf283996de5896654f.tar.gz
gentoo-b719d5d8faffa4b6b780e5cf283996de5896654f.tar.bz2
gentoo-b719d5d8faffa4b6b780e5cf283996de5896654f.zip
xfce-extra/xfce4-clipman-plugin: bump to 1.4.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index e16aa742628a..5af52a84ef10 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-clipman-plugin-1.2.6.tar.bz2 438346 SHA256 23043f99c3e5257d1f3d68b5ee5125e3469c15620d098e22c6250386197f48a5 SHA512 fc6b4cee1990ff13f4c0050ebf3e4b69fc0f7124fa2dd9b41933ce11449d322fad666b1af82bd610ce2add28d012a7dddc345be4afa1432bb330ecd6344a168e WHIRLPOOL 6fa94e6e364c1a10e9de6cd80a1fad889a411ea3ca533647bf10f73967c60f1ad10caeefb0e838977b2b01f550a88561b196eba1f42949f00edb76103ec8ed2c
+DIST xfce4-clipman-plugin-1.4.0.tar.bz2 471045 SHA256 a97671540663df1d90503f73695ac36e16fa2c832be8845ad9402529b8148294 SHA512 69579fc8d492bdde17ea00dc6329bc0c48c89c6e4e73fd99e0bb8e66ed095a302082106e667112dbb52bcbf91c295d6fcffa1712e8222c18b8cdeabf5c117011 WHIRLPOOL 29fb4ea07ea40fa2198602012ce68470898ac32ac3f78de66caa1ecbee9ef304d2d30bcdfd387a789ba7fa04037db12588945f7309ccba7cf5869377239e1010
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.0.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.0.ebuild
new file mode 100644
index 000000000000..82904c0e7283
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug qrcode"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.14:3=
+ dev-libs/libunique:1
+ x11-libs/libXtst
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.10:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable qrcode libqrencode)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}